CVE-2026-105626
CVE-2026-105626 · Consul vulnerable to a denial of service in HTTP APIs
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an unauthenticated attacker to exhaust memory on a Consul agent. This vulnerability (CVE-2026-105626) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.
CVSS 7.5 · Высокий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
consul
- Версии
- ≥ 0.6.0, < 2.1.0: Затронуто (semver)
Обновитесь до 2.1.0
consul enterprise
- Версии
- ≥ 0.6.0, < 2.1.0: Затронуто; ≥ 1.21.19: Не затронуто (semver)
Обновитесь до 1.21.19
consul Ubuntu:18.04:LTS
- Версии
- 0.6.4~dfsg-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
consul Ubuntu:20.04:LTS
- Версии
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
consul Ubuntu:22.04:LTS
- Версии
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления