CVE-2026-105856
CVE-2026-105856 · Payload: SQL injection in SQLite/Postgres
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Payload is a free and open source headless content management system. Prior to 3.90.0 and 4.0.0-canary.34, an attacker with read and create or update access to a collection containing a json field or a blocks field with blocksAsJSON enabled can inject SQL through a crafted field path and operators. Collections without those fields are not affected, and richText fields are not affected. The SQLite packages are fixed in versions 3.90.0 and 4.0.0-canary.34, and the Postgres packages are fixed in version 3.73.0.
CVSS 8.6 · Высокий · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
payload
- Версии
- >= 3.0.0, < 3.90.0: Затронуто
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Затронуто
Нет опубликованного исправления
db-d1-sqlite
- Версии
- >= 3.0.0, < 3.90.0: Затронуто
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Затронуто
Нет опубликованного исправления
db-postgres
- Версии
- >= 3.0.0 < 3.73.0: Затронуто
Нет опубликованного исправления
db-sqlite
- Версии
- >= 3.0.0, < 3.90.0: Затронуто
- >= 4.0.0-canary.0, < 4.0.0-canary.34: Затронуто
Нет опубликованного исправления
db-vercel-postgres
- Версии
- >= 3.0.0 < 3.73.0: Затронуто
Нет опубликованного исправления
@payloadcms/db-sqlite npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.90.0
Обновитесь до 3.90.0
@payloadcms/db-d1-sqlite npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.90.0
Обновитесь до 3.90.0
@payloadcms/db-postgres npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.73.0
Обновитесь до 3.73.0
@payloadcms/db-vercel-postgres npm
- Затронутые диапазоны версий
- SEMVER: ≥ 3.0.0, < 3.73.0
Обновитесь до 3.73.0
@payloadcms/db-sqlite npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Обновитесь до 4.0.0-canary.34
@payloadcms/db-d1-sqlite npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.0.0-canary.0, < 4.0.0-canary.34
Обновитесь до 4.0.0-canary.34