p PatchFirst

CVE-2026-106456

CVE-2026-106456 · Backstage: Inconsistent credential enforcement for overlapping proxy routes

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.

CVSS 4.8 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • backstage

    Версии
    • >= 1.28.0, < 1.55.0: Затронуто

    Нет опубликованного исправления

  • plugin-proxy-backend

    Версии
    • >= 0.5.0, < 0.6.18: Затронуто

    Нет опубликованного исправления

  • @backstage/plugin-proxy-backend npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 0.5.0, < 0.6.18

    Обновитесь до 0.6.18

Первоисточники

Проверьте свой сервер →