CVE-2026-106457
CVE-2026-106457 · Backstage: Insufficient audience validation in the Cloudflare Access auth provider
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Backstage is an open framework for building developer portals. From 0.1.0 until 0.5.0, the @backstage/plugin-auth-backend-module-cloudflare-access-provider package is affected by insufficient audience validation in the cloudflare access auth provider. The Cloudflare Access auth provider verifies a token's signature and team issuer, but affected versions do not verify that the token was issued for the Backstage application. A user holding a valid token for another Access application in the same Cloudflare Zero Trust team may therefore be able to authenticate to Backstage if that token reaches the auth endpoint without the Backstage application's audience already being enforced upstream. Cloudflare Access normally evaluates the protected application before forwarding requests. This issue is fixed in version 0.5.0.
CVSS 6.8 · Средний · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
backstage
- Версии
- >= 1.26.0, < 1.55.0: Затронуто
Нет опубликованного исправления
plugin-auth-backend-module-cloudflare-access-provider
- Версии
- >= 0.1.0, < 0.5.0: Затронуто
Нет опубликованного исправления
@backstage/plugin-auth-backend-module-cloudflare-access-provider npm
- Затронутые диапазоны версий
- SEMVER: ≥ 0.1.0, < 0.5.0
Обновитесь до 0.5.0