p PatchFirst

CVE-2026-106491

CVE-2026-106491 · Backstage: Improper input validation in proxy-backend

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the configured base path on the target server. This is limited to target servers already configured as proxy endpoints and requires Backstage authentication by default. This issue is fixed in version 0.6.17.

CVSS 6.4 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • backstage

    Версии
    • < 1.54.6: Затронуто

    Нет опубликованного исправления

  • plugin-proxy-backend

    Версии
    • < 0.6.17: Затронуто

    Нет опубликованного исправления

  • @backstage/plugin-proxy-backend npm

    Затронутые диапазоны версий
    • SEMVER: < 0.6.17

    Обновитесь до 0.6.17

Первоисточники

Проверьте свой сервер →