p PatchFirst

CVE-2026-106501

CVE-2026-106501 · Backstage: Sensitive information exposure in Scaffolder

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Backstage is an open framework for building developer portals. Prior to 3.3.1, 3.4.1, 4.0.3 and 4.1.0, the @backstage/plugin-scaffolder-backend package is affected by sensitive information exposure in scaffolder. An authenticated Backstage user who can read another user's Scaffolder task may receive internal execution data. In deployments where that data contains credentials for an external service, this may permit disclosure and unauthorized changes in that external service. This issue is fixed in versions 3.3.1, 3.4.1, 4.0.3 and 4.1.0.

CVSS 9.6 · Критический · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • backstage

    Версии
    • < 1.49.6: Затронуто
    • >= 1.50.0-next.0, < 1.50.5: Затронуто
    • >= 1.51.0-next.0, < 1.54.6: Затронуто

    Нет опубликованного исправления

  • plugin-scaffolder-backend

    Версии
    • < 3.3.1: Затронуто
    • >= 3.4.0, < 3.4.1: Затронуто
    • >= 4.0.0, < 4.0.3: Затронуто
    • >= 4.0.4, < 4.1.0: Затронуто

    Нет опубликованного исправления

  • @backstage/plugin-scaffolder-backend npm

    Затронутые диапазоны версий
    • SEMVER: < 3.3.1

    Обновитесь до 3.3.1

  • @backstage/plugin-scaffolder-backend npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.4.0, < 3.4.1

    Обновитесь до 3.4.1

  • @backstage/plugin-scaffolder-backend npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.0.3

    Обновитесь до 4.0.3

  • @backstage/plugin-scaffolder-backend npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.4, < 4.1.0

    Обновитесь до 4.1.0

Первоисточники

Проверьте свой сервер →