p PatchFirst

CVE-2026-106563

CVE-2026-106563 · Backstage: Improper entity validation in deprecated Kubernetes services endpoint

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Backstage is an open framework for building developer portals. Prior to 0.21.8, the @backstage/plugin-kubernetes-backend package is affected by improper entity validation in deprecated kubernetes services endpoint. An authenticated user with Kubernetes read permissions could access Kubernetes workload data beyond their intended scope by supplying crafted entity data to the deprecated services endpoint. The exposure is limited to read-only access to Kubernetes object metadata across configured clusters. This issue is fixed in version 0.21.8.

CVSS 5.3 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • backstage

    Версии
    • < 1.54.1: Затронуто

    Нет опубликованного исправления

  • plugin-kubernetes-backend

    Версии
    • < 0.21.8: Затронуто

    Нет опубликованного исправления

  • @backstage/plugin-kubernetes-backend npm

    Затронутые диапазоны версий
    • SEMVER: < 0.21.8

    Обновитесь до 0.21.8

Первоисточники

Проверьте свой сервер →