p PatchFirst

CVE-2026-10692

CVE-2026-10692 · johnhuang316 code-index-mcp search_code_advanced is_safe_regex_pattern redos

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A weakness has been identified in johnhuang316 code-index-mcp up to 2.14.0. Affected is the function is_safe_regex_pattern of the component search_code_advanced. Executing a manipulation of the argument regex can lead to inefficient regular expression complexity. It is possible to launch the attack remotely. The exploit has been made available to the public and could be used for attacks. Upgrading to version 2.14.1 is able to address this issue. This patch is called 25bc02fac74051ddae15ce79e952f00211b1ea6b. Upgrading the affected component is recommended.

CVSS 5.3 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • code-index-mcp

    Версии
    • 2.0: Затронуто
    • 2.1: Затронуто
    • 2.2: Затронуто
    • 2.3: Затронуто
    • 2.4: Затронуто
    • 2.5: Затронуто
    • 2.6: Затронуто
    • 2.7: Затронуто
    • 2.8: Затронуто
    • 2.9: Затронуто
    • 2.10: Затронуто
    • 2.11: Затронуто
    • 2.12: Затронуто
    • 2.13: Затронуто
    • 2.14.0: Затронуто
    • 2.14.1: Не затронуто

    Обновитесь до 2.14.1

  • code-index-mcp PyPI

    Версии
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 0.3.1
    • 0.4.1
    • 0.4.2
    • 0.5.0
    • 1.0.0
    • 1.1.0
    • 1.1.1
    • 1.2.0
    • 1.2.1
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.2
    • 2.10.0
    • 2.11.0
    • 2.12.0
    • 2.13.0
    • 2.14.0
    • 2.2.0
    • 2.2.1
    • 2.3.0
    • 2.3.1
    • 2.3.2
    • 2.4.0
    • 2.4.1
    • 2.5.0
    • 2.5.1
    • 2.6.0
    • 2.7.0
    • 2.8.0
    • 2.8.1
    • 2.9.0
    • 2.9.1
    • 2.9.2
    • 2.9.3
    • 2.9.4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.14.1

    Обновитесь до 2.14.1

Первоисточники

Проверьте свой сервер →