p PatchFirst

CVE-2026-109841

CVE-2026-109841 · undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

undici is an HTTP client library for Node.js. In versions 7.15.0 through 7.30.0 and 8.0.0 through 8.12.1, its fetch() implementation verifies Subresource Integrity metadata by matching the algorithm token against a lowercase-only set, even though the SRI specification defines the token by its ASCII-lowercase form, so a valid but non-lowercase token such as an uppercase or mixed-case SHA256 is treated as unknown and skipped. When no recognized algorithm remains, undici treats the integrity list as empty and accepts the response, so a server returning a body that does not match the pinned digest passes the check. An attacker who controls only the response body can therefore deliver attacker-controlled bytes to an application that pinned a valid uppercase or mixed-case SRI token, with no integrity error, affecting response integrity only. The issue is fixed in undici 7.30.1 and 8.12.2, which normalize the algorithm token to ASCII lowercase before validation, and users should upgrade to one of those versions or later. As a workaround, use lowercase algorithm tokens such as sha256, sha384, or sha512 in integrity metadata.

CVSS 5.9 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • undici

    Версии
    • ≥ 7.15.0, < 7.30.1: Затронуто (semver)
    • 7.30.1: Не затронуто (semver)
    • ≥ 8.0.0, < 8.12.2: Затронуто (semver)
    • 8.12.2: Не затронуто (semver)

    Обновитесь до 7.30.1; Обновитесь до 8.12.2

  • node-undici Debian:14

    Версии
    • 7.15.0+dfsg+~cs3.2.0-1
    • 7.15.0+dfsg+~cs3.2.0-3
    • 7.16.0+dfsg+~cs3.2.0-1
    • 7.16.0+dfsg+~cs3.2.0-2
    • 7.18.2+dfsg+~cs3.2.0-1
    • 7.24.5+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-2
    • 7.24.6+dfsg+~cs3.2.0-3
    • 7.3.0+dfsg1+~cs24.12.11-1
    • 7.3.0+dfsg1+~cs24.12.11-2
    • 8.10.2+dfsg+~cs3.2.2-1
    • 8.12.1+dfsg+~cs3.2.3-1
    • 8.12.2+dfsg+~cs3.2.3-1
    • 8.12.2+dfsg+~cs3.2.3-2
    • 8.5.0+dfsg+~cs3.2.0-1
    • 8.5.0+dfsg+~cs3.2.0-2
    • 8.5.0+dfsg+~cs3.2.0-3
    • 8.9.0+dfsg+~cs3.2.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • undici npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 7.15.0, < 7.30.1

    Обновитесь до 7.30.1

  • undici npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.12.2

    Обновитесь до 8.12.2

  • node-undici Ubuntu:24.04:LTS

    Версии
    • 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1
    • 5.26.3+dfsg1+~cs23.10.12-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-undici Ubuntu:26.10

    Версии
    • 7.18.2+dfsg+~cs3.2.0-1build1
    • 7.24.6+dfsg+~cs3.2.0-3
    • 8.5.0+dfsg+~cs3.2.0-2
    • 8.5.0+dfsg+~cs3.2.0-3
    • 8.9.0+dfsg+~cs3.2.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-undici Ubuntu:26.04:LTS

    Версии
    • 7.3.0+dfsg1+~cs24.12.11-2
    • 7.16.0+dfsg+~cs3.2.0-2
    • 7.18.2+dfsg+~cs3.2.0-1
    • 7.18.2+dfsg+~cs3.2.0-1build1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →