p PatchFirst

CVE-2026-111181

CVE-2026-111181 · body-parser vulnerable to Denial of Service via trailing bytes after a compressed request body

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

body-parser is body parsing middleware for Node.js and Express. In versions before 1.20.9 and in versions from 2.0.0 before 2.4.0, a single request can crash any application using body-parser with default options. When a request carries a Content-Encoding such as gzip, body-parser pipes it into a decompression stream and, after reading the body, leaves that stream with no error listener. A payload of one valid compressed frame followed by trailing bytes decodes and the application responds normally, but the trailing bytes then reach the already-finished decoder, which emits an error that is re-thrown as an uncaught exception and terminates the process. No matching route is required because body parsing runs before routing, so any endpoint that parses a body is affected. The issue is fixed in body-parser 2.4.0 and 1.20.9, and users should upgrade to one of those versions or later. As a workaround, disable request-body inflation (set the body-parser inflate option to false) so encoded requests are rejected before any decompression stream is created.

CVSS 7.5 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • body-parser

    Версии
    • ≥ 2.0.0, < 2.4.0: Затронуто (semver)
    • 2.4.0: Не затронуто (semver)
    • ≥ 0, < 1.20.9: Затронуто (semver)
    • 1.20.9: Не затронуто (semver)

    Обновитесь до 1.20.9; Обновитесь до 2.4.0

  • node-body-parser Debian:12

    Версии
    • 1.20.1+~1.19.2-1
    • 1.20.2+~1.19.5-1
    • 1.20.3+~1.19.5-1
    • 1.20.3+~1.19.5-2
    • 1.20.3+~1.19.5-3
    • 2.2.0+~1.19.6-1
    • 2.2.0+~1.19.6-2
    • 2.2.0+~1.19.6-3
    • 2.2.1+~1.19.6-1
    • 2.2.2+~1.19.6-1
    • 2.3.0+~1.19.6-1
    • 2.4.0+~1.19.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-body-parser Debian:13

    Версии
    • 1.20.3+~1.19.5-3
    • 2.2.0+~1.19.6-1
    • 2.2.0+~1.19.6-2
    • 2.2.0+~1.19.6-3
    • 2.2.1+~1.19.6-1
    • 2.2.2+~1.19.6-1
    • 2.3.0+~1.19.6-1
    • 2.4.0+~1.19.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-body-parser Debian:14

    Версии
    • 1.20.3+~1.19.5-3
    • 2.2.0+~1.19.6-1
    • 2.2.0+~1.19.6-2
    • 2.2.0+~1.19.6-3
    • 2.2.1+~1.19.6-1
    • 2.2.2+~1.19.6-1
    • 2.3.0+~1.19.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 2.4.0+~1.19.6-1

    Обновитесь до 2.4.0+~1.19.6-1

  • body-parser npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.0.0, < 2.4.0

    Обновитесь до 2.4.0

  • body-parser npm

    Затронутые диапазоны версий
    • SEMVER: < 1.20.9

    Обновитесь до 1.20.9

  • node-body-parser Ubuntu:16.04:LTS

    Версии
    • 1.8.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-body-parser Ubuntu:18.04:LTS

    Версии
    • 1.8.1-1
    • 1.8.1-1ubuntu1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-body-parser Ubuntu:20.04:LTS

    Версии
    • 1.18.3-2
    • 1.19.0-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-body-parser Ubuntu:22.04:LTS

    Версии
    • 1.19.0-2
    • 1.19.0-5
    • 1.19.1+~1.19.2-1
    • 1.19.2+~1.19.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-body-parser Ubuntu:24.04:LTS

    Версии
    • 1.20.1+~1.19.2-1
    • 1.20.2+~1.19.5-1
    • 1.20.2+~1.19.5-1build2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-body-parser Ubuntu:26.10

    Версии
    • 2.2.2+~1.19.6-1
    • 2.3.0+~1.19.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-body-parser Ubuntu:26.04:LTS

    Версии
    • 1.20.3+~1.19.5-3
    • 2.2.0+~1.19.6-1
    • 2.2.2+~1.19.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →