CVE-2026-111804
CVE-2026-111804 · Apache Traffic Server: wasm plugin has a use-after-free and forwards unvalidated guest metric IDs
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Apache Traffic Server's experimental wasm plugin has a use-after-free in its transaction-close handler and forwards unvalidated guest-supplied metric IDs to the internal stats API. This issue affects Apache Traffic Server: from 10.0.0 through 10.1.4, 10.2.0. Users are recommended to upgrade to version 10.1.5 or 10.2.1, which fix the issue.
CVSS 8.8 · Высокий · EPSS 0,3%
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
apache traffic server
- Версии
- ≥ 10.0.0, ≤ 10.1.4: Затронуто (semver)
- 10.2.0: Затронуто (semver)
Нет опубликованного исправления
trafficserver Debian:12
- Версии
- 9.2.0+ds-2
- 9.2.0+ds-2+deb12u1
- 9.2.1+ds-1
- 9.2.2+ds-1
- 9.2.3+ds-1
- 9.2.3+ds-1+deb12u1
- 9.2.4+ds-0+deb12u1
- 9.2.4+ds-1
- 9.2.4+ds-2
- 9.2.5+ds-0+deb12u1
- 9.2.5+ds-0+deb12u2
- 9.2.5+ds-0+deb12u3
- 9.2.5+ds-0+deb12u4
- 9.2.5+ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
trafficserver Ubuntu:16.04:LTS
- Версии
- 5.3.0-2ubuntu1
- 5.3.0-2ubuntu2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
trafficserver Ubuntu:18.04:LTS
- Версии
- 7.0.0-5
- 7.1.2+ds-2
- 7.1.2+ds-2build1
- 7.1.2+ds-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
trafficserver Ubuntu:Pro:20.04:LTS
- Версии
- 8.0.5+ds-1
- 8.0.5+ds-2
- 8.0.5+ds-2build1
- 8.0.5+ds-2ubuntu1
- 8.0.5+ds-3
- 8.0.5+ds-3ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
trafficserver Ubuntu:Pro:22.04:LTS
- Версии
- 8.1.1+ds-1.1
- 9.1.1+ds-2build1
- 9.1.1+ds-2ubuntu0.1~esm1
- 9.1.1+ds-2ubuntu0.1
- 9.1.1+ds-2ubuntu0.1+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
trafficserver Ubuntu:24.04:LTS
- Версии
- 9.2.1+ds-1build1
- 9.2.2+ds-1
- 9.2.3+ds-1
- 9.2.3+ds-1+deb12u1
- 9.2.3+ds-1+deb12u1build1
- 9.2.3+ds-1+deb12u1build3
- 9.2.3+ds-1+deb12u1build4
- 9.2.3+ds-1+deb12u1ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления