p PatchFirst

CVE-2026-112942

CVE-2026-112942 · launch-editor: `fs.existsSync()` existence check can be bypassed on Windows

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to 2.14.2, launch-editor-middleware processes an attacker-controlled Windows file argument where the file argument ends in a parent-directory component plus a line-and-column suffix: the path is resolved while the suffix is still present, and launch-editor removes the suffix before its existsSync check, leaving the existing parent directory for existsSync and allowing the attacker-controlled file argument to pass filename existence validation without requiring the malicious filename to exist. The bypass can lead to OS command injection when combined with the separately described Windows percent-expansion flaw. This issue is fixed in version 2.14.2.

CVSS 7.5 · Высокий · EPSS 1,3% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • launch-editor

    Версии
    • < 2.14.2: Затронуто

    Нет опубликованного исправления

  • vite

    Версии
    • >= 8.3.0, < 8.3.3: Затронуто
    • >= 8.2.0, < 8.2.4: Затронуто
    • >= 8.0.0, < 8.1.6: Затронуто
    • >= 7.0.0, < 7.3.7: Затронуто
    • < 6.4.4: Затронуто

    Нет опубликованного исправления

  • vite-plus

    Версии
    • < 1.1.0: Затронуто

    Нет опубликованного исправления

  • launch-editor npm

    Затронутые диапазоны версий
    • SEMVER: < 2.14.2

    Обновитесь до 2.14.2

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.3.0, < 8.3.3

    Обновитесь до 8.3.3

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.2.0, < 8.2.4

    Обновитесь до 8.2.4

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.1.6

    Обновитесь до 8.1.6

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 7.0.0, < 7.3.7

    Обновитесь до 7.3.7

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: < 6.4.4

    Обновитесь до 6.4.4

  • vite-plus npm

    Затронутые диапазоны версий
    • SEMVER: < 1.1.0

    Обновитесь до 1.1.0

Первоисточники

Проверьте свой сервер →