p PatchFirst

CVE-2026-112944

CVE-2026-112944 · launch-editor: Editor CLI flag misinterpretation causing arbitrary command execution for some editors

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

launch-editor allows users to open files with line numbers in editor from Node.js. Prior to 2.14.2, when an attacker can create a filesystem entry beginning with plus or minus in the working directory, an affected editor is selected, and the path can remain relative or is converted to a relative WSL path, launchEditor forwards the path without forcing it to be interpreted as a positional filename. Editor option parsing then treats the attacker-controlled filename as a command-line flag, which can cause unintended file overwrite or arbitrary command execution by the selected editor. The affected editors are Vim and gVim, MacVim, Emacs and Emacsclient, and Notepad++ when a plugin exposes dangerous operations; WSL path conversion keeps Vite and newer middleware callers exposed. This issue is fixed in version 2.14.2.

CVSS 6.3 · Средний · EPSS 0,7% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • launch-editor

    Версии
    • < 2.14.2: Затронуто

    Нет опубликованного исправления

  • vite

    Версии
    • >= 8.3.0, < 8.3.3: Затронуто
    • >= 8.2.0, < 8.2.4: Затронуто
    • >= 8.0.0, < 8.1.6: Затронуто
    • >= 7.0.0, < 7.3.7: Затронуто
    • < 6.4.4: Затронуто

    Нет опубликованного исправления

  • vite-plus

    Версии
    • < 1.1.0: Затронуто

    Нет опубликованного исправления

  • launch-editor npm

    Затронутые диапазоны версий
    • SEMVER: < 2.14.2

    Обновитесь до 2.14.2

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.3.0, < 8.3.3

    Обновитесь до 8.3.3

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.2.0, < 8.2.4

    Обновитесь до 8.2.4

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 8.0.0, < 8.1.6

    Обновитесь до 8.1.6

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 7.0.0, < 7.3.7

    Обновитесь до 7.3.7

  • vite npm

    Затронутые диапазоны версий
    • SEMVER: < 6.4.4

    Обновитесь до 6.4.4

  • vite-plus npm

    Затронутые диапазоны версий
    • SEMVER: < 1.1.0

    Обновитесь до 1.1.0

Первоисточники

Проверьте свой сервер →