p PatchFirst

CVE-2026-114135

CVE-2026-114135 · Jupyter Server: Gateway WebSocket handler bypasses kernel execute authorization

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Jupyter Server is the backend for Jupyter web applications. From 2.0.0 until 2.6.0, enabling GatewayClient.url replaced the normal KernelWebsocketHandler with WebSocketChannelsHandler, which authenticated the user but did not call authorizer.is_authorized(...) for the execute action on the kernels resource. A restricted authenticated user could therefore open an upstream kernel channel and obtain kernel execution despite the configured Authorizer denying that action, exposing data and credentials available to the kernel and permitting modification or disruption of the kernel environment. The default gateway configuration is fixed in version 2.6.0. In 2.6.0 and later, the same authorization bypass remains possible when a deployment manually registers the deprecated jupyter_server.gateway.handlers module, because its handler still omits the configured kernel-execute authorization decision.

CVSS 8.8 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • jupyter_server

    Версии
    • >= 2.0.0, < 2.6.0: Затронуто

    Нет опубликованного исправления

  • jupyter-server Debian:12

    Версии
    • 1.23.3-1
    • 1.23.3-2
    • 2.14.0-1
    • 2.14.2-1
    • 2.14.2-2
    • 2.14.2-3
    • 2.14.2-4
    • 2.14.2-5
    • 2.15.0-1
    • 2.17.0-1
    • 2.20.0-1
    • 2.20.0-2
    • 2.20.0-3
    • 2.9.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Debian:13

    Версии
    • 2.15.0-1
    • 2.17.0-1
    • 2.20.0-1
    • 2.20.0-2
    • 2.20.0-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Debian:14

    Версии
    • 2.15.0-1
    • 2.17.0-1
    • 2.20.0-1
    • 2.20.0-2
    • 2.20.0-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server PyPI

    Версии
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.5
    • 2.0.6
    • 2.0.7
    • 2.1.0
    • 2.2.0
    • 2.2.1
    • 2.3.0
    • 2.4.0
    • 2.5.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 2.0.0, < 2.6.0

    Обновитесь до 2.6.0

  • jupyter-server Ubuntu:22.04:LTS

    Версии
    • 1.2.2-1
    • 1.13.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Ubuntu:24.04:LTS

    Версии
    • 1.23.3-1
    • 1.23.3-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Ubuntu:26.10

    Версии
    • 2.17.0-1
    • 2.20.0-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • jupyter-server Ubuntu:26.04:LTS

    Версии
    • 2.15.0-1
    • 2.17.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →