p PatchFirst

CVE-2026-115419

CVE-2026-115419 · Unintended disclosure of data element to wrong session in Strands Agents SDK A2A Server

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

The A2A server component in Amazon Strands Agents SDK for Python before 1.43.0 and Amazon Strands Agents SDK for TypeScript before 1.5.0 does not properly isolate conversation state between callers. An authenticated remote user could read other tenants' conversation history and add persistent instructions that alter model behavior for subsequent callers via HTTP requests to the A2A endpoint using a different context_id. To mitigate this issue, users should upgrade to strands-agents 1.43.0 (Python) or @strands-agents/sdk 1.5.0 (TypeScript).

CVSS 8.6 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: python · node

Затронутые продукты и версии

  • strands-agents

    Версии
    • ≥ 0, < 1.43.0: Затронуто (custom)

    Обновитесь до 1.43.0

  • strands-agents/sdk

    Версии
    • ≥ 0, < 1.5.0: Затронуто (custom)

    Обновитесь до 1.5.0

  • strands-agents PyPI

    Версии
    • 0.0.1
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.1.6
    • 0.1.7
    • 0.1.8
    • 0.1.9
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.10.0
    • 1.11.0
    • 1.12.0
    • 1.13.0
    • 1.14.0
    • 1.15.0
    • 1.16.0
    • 1.17.0
    • 1.18.0
    • 1.19.0
    • 1.2.0
    • 1.20.0
    • 1.21.0
    • 1.22.0
    • 1.23.0
    • 1.24.0
    • 1.25.0
    • 1.26.0
    • 1.27.0
    • 1.28.0
    • 1.29.0
    • 1.3.0
    • 1.30.0
    • 1.31.0
    • 1.32.0
    • 1.33.0
    • 1.34.0
    • 1.34.1
    • 1.35.0
    • 1.36.0
    • 1.37.0
    • 1.38.0
    • 1.39.0
    • 1.4.0
    • 1.40.0
    • 1.41.0
    • 1.42.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 1.7.1
    • 1.8.0
    • 1.9.0
    • 1.9.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.43.0

    Обновитесь до 1.43.0

  • @strands-agents/sdk npm

    Затронутые диапазоны версий
    • SEMVER: < 1.5.0

    Обновитесь до 1.5.0

Первоисточники

Проверьте свой сервер →