CVE-2026-115586
CVE-2026-115586 · virtualenv: Bash activator leaves the --prompt value unescaped in PS1 when promptvars is off, so prompt expansion later executes it (regression in 21.14.9)
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
virtualenv is a tool for creating isolated virtual python environments. From 21.14.9 until 21.14.13, the bash bin/activate script can copy an attacker-controlled --prompt value into PS1 without escaping dollar signs or backticks when both promptvars and POSIX mode are disabled during activation. Re-enabling promptvars, running set -o posix, or starting an interactive child bash that inherits the exported PS1 can then expand command substitution in the stored VIRTUAL_ENV_PROMPT value and execute commands as the user who activates the environment. This issue is fixed in version 21.14.13.
CVSS 7.1 · Высокий · EPSS 0,2% · Публичный эксплойт · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
virtualenv
- Версии
- >= 21.14.9, < 21.14.13: Затронуто
Нет опубликованного исправления
virtualenv PyPI
- Версии
- 21.14.10
- 21.14.11
- 21.14.12
- 21.14.9
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 21.14.9, < 21.14.13
Обновитесь до 21.14.13
python-virtualenv Ubuntu:14.04:LTS
- Версии
- 1.10.1-1
- 1.11-1
- 1.11-2
- 1.11.4-1
- 1.11.4-1ubuntu1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
python-virtualenv Ubuntu:16.04:LTS
- Версии
- 1.11.6+ds-1
- 14.0.5+ds-1
- 14.0.5+ds-2
- 14.0.5+ds-4
- 15.0.0+ds-1
- 15.0.0+ds-2
- 15.0.1+ds-1
- 15.0.1+ds-2
- 15.0.1+ds-3
- 15.0.1+ds-3ubuntu1
- 15.0.1+ds-3ubuntu1.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
python-virtualenv Ubuntu:18.04:LTS
- Версии
- 15.1.0+ds-1
- 15.1.0+ds-1.1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
python-virtualenv Ubuntu:Pro:20.04:LTS
- Версии
- 15.1.0+ds-2
- 15.1.0+ds-2build1
- 15.1.0+ds-2ubuntu1
- 20.0.13-1
- 20.0.17-1
- 20.0.17-1ubuntu0.3
- 20.0.17-1ubuntu0.4
- 20.0.17-1ubuntu0.4+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
python-virtualenv Ubuntu:Pro:22.04:LTS
- Версии
- 20.4.6+ds-2
- 20.10.0+ds-1
- 20.12.1+ds-1
- 20.13.0+ds-1
- 20.13.0+ds-2
- 20.13.0+ds-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
python-virtualenv Ubuntu:Pro:24.04:LTS
- Версии
- 20.24.1+ds-1
- 20.24.6+ds-1
- 20.24.6+ds-2
- 20.25.0+ds-1
- 20.25.0+ds-2
- 20.25.0+ds-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
python-virtualenv Ubuntu:26.10
- Версии
- 20.36.1+ds-1
- 21.4.1+ds-1
- 21.5.1+ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
python-virtualenv Ubuntu:26.04:LTS
- Версии
- 20.31.2+ds-1
- 20.35.3+ds-1
- 20.35.4+ds-1
- 20.36.1+ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/pypa/virtualenv/security/advisories/GHSA-cx6f-vjhg-g3cc
- https://github.com/pypa/virtualenv/pull/3466
- https://github.com/pypa/virtualenv/commit/3598e201f6f044e389136b2347a8a919ac03c5f4
- https://github.com/pypa/virtualenv/releases/tag/21.14.13
- https://nvd.nist.gov/vuln/detail/CVE-2026-115586