p PatchFirst

CVE-2026-115910

CVE-2026-115910 · Python Social Auth: OpenID Connect nonce is not bound to the browser session, so a stolen authorization code logs the attacker in as the victim

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Python Social Auth is a social authentication and registration mechanism. Prior to 6.2.0, OpenIdConnectAuth in social_core/backends/open_id_connect.py uses get_and_store_nonce to place the OpenID Connect nonce in a shared OpenIdConnectAssociation table, and get_nonce and validate_claims verify only that the nonce exists and has not expired rather than binding it to the browser session and OAuth state that initiated the login. An attacker who obtains a victim's unused authorization code can start a separate login to obtain valid state for the attacker's browser, submit the victim's code with that state, and pass nonce validation because the victim nonce is globally available. With DEFAULT_USE_PKCE disabled in the default OpenIdConnectAuth configuration, the attacker can be logged in as the victim. This issue is fixed in version 6.2.0.

CVSS 6.8 · Средний · EPSS 0,2% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • social-core

    Версии
    • < 6.2.0: Затронуто

    Нет опубликованного исправления

  • social-auth-core Debian:12

    Версии
    • 4.3.0-1
    • 4.4.2-1
    • 4.4.2-2
    • 4.5.3-1
    • 4.5.4-1
    • 4.5.6-1
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    • 5.0.2-1
    • 5.1.0-1
    • 5.1.0-2
    • 5.1.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • social-auth-core Debian:13

    Версии
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    • 5.0.2-1
    • 5.1.0-1
    • 5.1.0-2
    • 5.1.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • social-auth-core Debian:14

    Версии
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    • 4.8.5-1
    • 4.8.7-1
    • 4.9.1-1
    • 5.0.2-1
    • 5.1.0-1
    • 5.1.0-2
    • 5.1.1-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • social-auth-core PyPI

    Версии
    • 0.0.1
    • 0.1.0
    • 0.2.0
    • 0.2.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.4.0
    • 1.5.0
    • 1.6.0
    • 1.7.0
    • 2.0.0
    • 3.0.0
    • 3.1.0
    • 3.2.0
    • 3.3.0
    • 3.3.1
    • 3.3.2
    • 3.3.3
    • 3.4.0
    • 4.0.2
    • 4.0.3
    • 4.1.0
    • 4.2.0
    • 4.3.0
    • 4.4.0
    • 4.4.1
    • 4.4.2
    • 4.5.0
    • 4.5.1
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.5.6
    • 4.6.0
    • 4.6.1
    • 4.7.0
    • 4.8.0
    • 4.8.1
    • 4.8.2
    • 4.8.3
    • 4.8.4
    • 4.8.5
    • 4.8.6
    • 4.8.7
    • 4.9.0
    • 4.9.1
    • 5.0.0
    • 5.0.1
    • 5.0.2
    • 5.1.0
    • 5.1.1
    • 5.2.0
    • 6.0.0
    • 6.1.0
    • 6.1.1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.2.0

    Обновитесь до 6.2.0

  • social-auth-core Ubuntu:20.04:LTS

    Версии
    • 3.1.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • social-auth-core Ubuntu:22.04:LTS

    Версии
    • 3.1.0-1.1
    • 4.1.0-1
    • 4.2.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • social-auth-core Ubuntu:24.04:LTS

    Версии
    • 4.4.2-2
    • 4.5.3-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • social-auth-core Ubuntu:26.10

    Версии
    • 4.8.3-1
    • 5.0.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • social-auth-core Ubuntu:26.04:LTS

    Версии
    • 4.6.1-1
    • 4.8.1-1
    • 4.8.3-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →