CVE-2026-116590
CVE-2026-116590 · snappy-java: JVM crash from unchecked ranges in Snappy.arrayCopy and SnappyOutputStream.rawWrite
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
snappy-java is a Java port of the snappy, a fast C++ compresser/decompresser developed by Google. Prior to 1.1.10.9, Snappy.arrayCopy(Object src, int offset, int byteLength, Object dest, int destOffset) passes caller-supplied ranges to native memcpy without validating either array, allowing negative or oversized byteLength and offset values to read or write outside array bounds and crash the JVM. SnappyOutputStream.rawWrite and SnappyInputStream.rawRead, including their typed-array write and read methods, pass caller-controlled ranges through this primitive, and typed-array byte-size calculations can overflow int. This issue is fixed in version 1.1.10.9.
CVSS 5.9 · Средний · EPSS 0,4%
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
snappy-java
- Версии
- < 1.1.10.9: Затронуто
Нет опубликованного исправления
snappy-java Debian:12
- Версии
- 1.1.10.5-1
- 1.1.10.5-2
- 1.1.10.7-1
- 1.1.10.8-1
- 1.1.8.3-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Debian:13
- Версии
- 1.1.10.7-1
- 1.1.10.8-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Debian:14
- Версии
- 1.1.10.7-1
- 1.1.10.8-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Ubuntu:14.04:LTS
- Версии
- 1.0.4.1~dfsg-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Ubuntu:16.04:LTS
- Версии
- 1.1.1.7-2
- 1.1.2-1
- 1.1.2.1-2
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Ubuntu:18.04:LTS
- Версии
- 1.1.4-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Ubuntu:20.04:LTS
- Версии
- 1.1.7.2-1
- 1.1.7.3-1
- 1.1.7.3-1build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Ubuntu:22.04:LTS
- Версии
- 1.1.8.3-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Ubuntu:24.04:LTS
- Версии
- 1.1.8.3-1
- 1.1.10.5-1
- 1.1.10.5-1build1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Ubuntu:26.10
- Версии
- 1.1.10.8-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
snappy-java Ubuntu:26.04:LTS
- Версии
- 1.1.10.7-1
- 1.1.10.8-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/xerial/snappy-java/security/advisories/GHSA-xqrx-qh46-34m7
- https://github.com/xerial/snappy-java/pull/741
- https://github.com/xerial/snappy-java/commit/2d7ca71c087a98f1219fb2d51909f3891c3ce77b
- https://github.com/xerial/snappy-java/releases/tag/v1.1.10.9
- https://nvd.nist.gov/vuln/detail/CVE-2026-116590