CVE-2026-118257
CVE-2026-118257 · Vue I18n: escapeParameter does not prevent XSS through srcdoc in translation messages
CVSS 7.2 · Высокий · EPSS 0,3% · Публичный эксплойт · Есть исправление
Затронуты ли вы?
- vue-i18nНет опубликованного исправления
- vue-i18n npmНет опубликованного исправления
- petite-vue-i18n npmНет опубликованного исправления
- @intlify/core-base npmНет опубликованного исправления
- и ещё 3
Как узнать установленную версию:
npm ls vue-i18nnpm ls petite-vue-i18nnpm ls @intlify/core-baseБесплатная проверка покажет рейтинг сервера и подсветит, требует ли внимания vue-i18n и остальные программы. Без регистрации; имена серверов и IP-адреса не отправляются. Номера CVE, версии исправлений и рекомендации — в платном мониторинге.
curl -fsSL https://ru.patchfirst.dev/check.sh | shЗдесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.
Vue I18n is the internationalization plugin for Vue.js. From 11.1.10 until 11.4.14 and from 12.0.0-alpha.4 until 12.0.0-alpha.5, sanitizeTranslatedHtml() escapes markup and event-handler text inside an iframe srcdoc value but leaves the srcdoc attribute active. Browsers decode the character references and parse the value as a same-origin nested HTML document, allowing attacker-controlled parameters or translation content placed in srcdoc to execute script when applications enable escapeParameter and render translations as HTML through v-html. Versions 9.14.5 and 10.0.8 are also affected and are no longer supported, while i18n-t rendering is not affected. This issue is fixed in versions 11.4.14 and 12.0.0-alpha.5.
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
vue-i18n
- Версии
- = 9.14.5: Затронуто
- = 10.0.8: Затронуто
- >= 11.1.10, < 11.4.14: Затронуто
- >= 12.0.0-alpha.4, < 12.0.0-alpha.5: Затронуто
Нет опубликованного исправления
vue-i18n npm
- Версии
- 9.14.5
Нет опубликованного исправления
vue-i18n npm
- Версии
- 10.0.8
Нет опубликованного исправления
vue-i18n npm
- Затронутые диапазоны версий
- SEMVER: ≥ 11.1.10, < 11.4.14
Обновитесь до 11.4.14
vue-i18n npm
- Версии
- 12.0.0-alpha.4
- Затронутые диапазоны версий
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Обновитесь до 12.0.0-alpha.5
petite-vue-i18n npm
- Версии
- 9.14.5
Нет опубликованного исправления
petite-vue-i18n npm
- Версии
- 10.0.8
Нет опубликованного исправления
petite-vue-i18n npm
- Затронутые диапазоны версий
- SEMVER: ≥ 11.1.10, < 11.4.14
Обновитесь до 11.4.14
petite-vue-i18n npm
- Версии
- 12.0.0-alpha.4
- Затронутые диапазоны версий
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Обновитесь до 12.0.0-alpha.5
@intlify/core-base npm
- Версии
- 9.14.5
Нет опубликованного исправления
@intlify/core-base npm
- Версии
- 10.0.8
Нет опубликованного исправления
@intlify/core-base npm
- Затронутые диапазоны версий
- SEMVER: ≥ 11.1.10, < 11.4.14
Обновитесь до 11.4.14
@intlify/core-base npm
- Версии
- 12.0.0-alpha.4
- Затронутые диапазоны версий
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Обновитесь до 12.0.0-alpha.5
@intlify/core npm
- Версии
- 9.14.5
Нет опубликованного исправления
@intlify/core npm
- Версии
- 10.0.8
Нет опубликованного исправления
@intlify/core npm
- Затронутые диапазоны версий
- SEMVER: ≥ 11.1.10, < 11.4.14
Обновитесь до 11.4.14
@intlify/core npm
- Версии
- 12.0.0-alpha.4
- Затронутые диапазоны версий
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Обновитесь до 12.0.0-alpha.5
@intlify/vue-i18n-core npm
- Версии
- 9.14.5
Нет опубликованного исправления
@intlify/vue-i18n-core npm
- Версии
- 10.0.8
Нет опубликованного исправления
@intlify/vue-i18n-core npm
- Затронутые диапазоны версий
- SEMVER: ≥ 11.1.10, < 11.4.14
Обновитесь до 11.4.14
@intlify/vue-i18n-core npm
- Версии
- 12.0.0-alpha.4
- Затронутые диапазоны версий
- SEMVER: ≥ 12.0.0-alpha.4, < 12.0.0-alpha.5
Обновитесь до 12.0.0-alpha.5
@intlify/shared npm
- Версии
- 9.14.5
Нет опубликованного исправления
@intlify/shared npm
- Версии
- 10.0.8
Нет опубликованного исправления
@intlify/shared npm
- Затронутые диапазоны версий
- SEMVER: ≥ 11.1.10, < 11.4.14
Обновитесь до 11.4.14
Первоисточники
- https://github.com/intlify/vue-i18n/security/advisories/GHSA-83rm-6c8r-g728
- https://github.com/intlify/vue-i18n/pull/2679
- https://github.com/intlify/vue-i18n/commit/43391d20e7c85403cb59bdb21b5d542819f54042
- https://github.com/intlify/vue-i18n/releases/tag/v11.4.14
- https://github.com/intlify/vue-i18n/releases/tag/v12.0.0-alpha.5
- https://nvd.nist.gov/vuln/detail/CVE-2026-118257