p PatchFirst

CVE-2026-119282

CVE-2026-119282 · Nx: OS command injection via nx.json plugin options in @nx/maven and @nx/gradle

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Nx is a monorepo solution for TypeScript and polyglot codebases. From 22.0.2 until 22.7.9 and 23.1.2 for @nx/maven, and from 21.0.0 until 22.7.9 and 23.1.2 for @nx/gradle, the plugins' project-graph analyzers launch through a shell and interpolate plugin options from nx.json into command arguments. The @nx/maven targetNamePrefix value and arbitrary @nx/gradle option names or values can therefore be interpreted as shell syntax whenever an nx command constructs the project graph. A user who runs Nx in an attacker-controlled repository or pull request can execute injected commands with the user's privileges, while workspaces that register neither affected plugin are not exposed to this path. Remediation requires upgrading both nx and each affected plugin to matching releases because the plugin fix depends on code in the nx package. This issue is fixed in versions 22.7.9 and 23.1.2.

CVSS 7.3 · Высокий · EPSS 0,1% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • nx

    Версии
    • >= 21.0.0, < 22.7.9: Затронуто
    • >= 23.0.0, < 23.1.2: Затронуто

    Нет опубликованного исправления

  • maven

    Версии
    • >= 21.0.0, < 22.7.9: Затронуто
    • >= 23.0.0, < 23.1.2: Затронуто

    Нет опубликованного исправления

  • gradle

    Версии
    • >= 21.0.0, < 22.7.9: Затронуто
    • >= 23.0.0, < 23.1.2: Затронуто

    Нет опубликованного исправления

  • @nx/maven npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 22.0.2, < 22.7.9

    Обновитесь до 22.7.9

  • @nx/maven npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 23.0.0, < 23.1.2

    Обновитесь до 23.1.2

  • @nx/gradle npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 21.0.0, < 22.7.9

    Обновитесь до 22.7.9

  • @nx/gradle npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 23.0.0, < 23.1.2

    Обновитесь до 23.1.2

Первоисточники

Проверьте свой сервер →