p PatchFirst

CVE-2026-15529

CVE-2026-15529 · yzhao062 pyod persistence.py pyod.utils.persistence.load deserialization

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

A vulnerability was detected in yzhao062 pyod up to 3.6.1. Affected is the function pyod.utils.persistence.load of the file pyod/utils/persistence.py. Performing a manipulation of the argument path results in deserialization. The attack can be initiated remotely. Upgrading to version 3.6.2 is able to address this issue. It is recommended to apply a patch to fix this issue. The pull request to fix this issue requires some minor changes.

CVSS 5.3 · Средний · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • pyod

    Версии
    • 3.5.0: Затронуто
    • 3.5.1: Затронуто
    • 3.5.2: Затронуто
    • 3.5.4: Затронуто
    • 3.6.0: Затронуто
    • 3.6.1: Затронуто
    • 3.6.2: Не затронуто

    Обновитесь до 3.6.2

  • pyod PyPI

    Версии
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.5.4
    • 3.6.0
    • 3.6.1
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 3.5.0, < 3.6.2

    Обновитесь до 3.6.2

Первоисточники

Проверьте свой сервер →