p PatchFirst

CVE-2026-18446

CVE-2026-18446 · fast-uri vulnerable to host confusion via backslash authority introducer

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

fast-uri before 4.1.2, 3.1.5, and 2.4.4 requires a literal double forward slash to recognize a URI authority, so a reference that uses a backslash based introducer in place of it (backslash backslash, forward slash backslash, or backslash forward slash) is parsed with no authority and folds into the path. Node's native WHATWG URL parser instead treats a backslash as interchangeable with a forward slash for special schemes, so the two parsers extract different hosts from the same input. Applications that use fast-uri to enforce host based policy such as allowlists, SSRF filtering, or redirect validation before passing the same URL into Node's URL or fetch consumers can be steered to an unintended host. Upgrade to fast-uri 4.1.2, 3.1.5, or 2.4.4.

CVSS 7.5 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: system · node

Затронутые продукты и версии

  • fast-uri

    Версии
    • ≥ 4.0.0, < 4.1.2: Затронуто (semver)
    • 4.1.2: Не затронуто (semver)
    • ≥ 3.0.0, < 3.1.5: Затронуто (semver)
    • 3.1.5: Не затронуто (semver)
    • ≥ 0, < 2.4.4: Затронуто (semver)
    • 2.4.4: Не затронуто (semver)

    Обновитесь до 2.4.4; Обновитесь до 3.1.5; Обновитесь до 4.1.2

  • node-ajv Debian:13

    Версии
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ajv Debian:14

    Версии
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.3-1

    Обновитесь до 8.20.0~ds+~cs7.1.3-1

  • fast-uri npm

    Затронутые диапазоны версий
    • SEMVER: < 2.4.4

    Обновитесь до 2.4.4

  • fast-uri npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 3.0.0, < 3.1.5

    Обновитесь до 3.1.5

  • fast-uri npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 4.0.0, < 4.1.2

    Обновитесь до 4.1.2

  • node-ajv Ubuntu:18.04:LTS

    Версии
    • 5.0.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ajv Ubuntu:20.04:LTS

    Версии
    • 6.10.2-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ajv Ubuntu:22.04:LTS

    Версии
    • 6.12.6-2
    • 6.12.6-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ajv Ubuntu:24.04:LTS

    Версии
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ajv Ubuntu:26.10

    Версии
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • node-ajv Ubuntu:26.04:LTS

    Версии
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →