CVE-2026-19016
CVE-2026-19016 · Authorization bypass for session deletion in the transaction API
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Consul Community Edition and Consul Enterprise 1.19.1 through 2.0.2 did not enforce the {{session:write}} ACL permission for session deletion operations submitted through the transaction API. An authenticated caller with network access to the Consul server RPC port could delete arbitrary sessions without holding the required permission. This vulnerability, CVE-2026-19016, is fixed in Consul 2.0.3 and Consul Enterprise 1.21.17, 1.22.11, and 2.0.3.
CVSS 4.2 · Средний · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
consul
- Версии
- ≥ 1.19.1, < 2.0.3: Затронуто (semver)
Обновитесь до 2.0.3
consul enterprise
- Версии
- ≥ 1.19.1, < 2.0.3: Затронуто; ≥ 1.21.17: Не затронуто; ≥ 1.22.11: Не затронуто (semver)
Обновитесь до 1.21.17
consul Debian:11
- Версии
- 1.10.12+dfsg1-1
- 1.8.7+dfsg1-2
- 1.8.7+dfsg1-3
- 1.8.7+dfsg1-4
- 1.8.7+dfsg1-5
- 1.8.7+dfsg1-6
- 1.9.17+dfsg2-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
consul Ubuntu:18.04:LTS
- Версии
- 0.6.4~dfsg-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
consul Ubuntu:20.04:LTS
- Версии
- 1.0.7~dfsg1-5ubuntu1
- 1.4.4~dfsg1-2ubuntu2
- 1.5.2+dfsg1-6
- 1.5.2+dfsg1-10
- 1.5.2+dfsg1-12
- 1.5.2+dfsg2-14
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
consul Ubuntu:22.04:LTS
- Версии
- 1.7.4+dfsg1-1
- 1.8.7+dfsg1-3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления