CVE-2026-22801
CVE-2026-22801 · LIBPNG has an integer truncation causing heap buffer over-read in png_image_write_*
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. From 1.6.26 to 1.6.53, there is an integer truncation in the libpng simplified write API functions png_write_image_16bit and png_write_image_8bit causes heap buffer over-read when the caller provides a negative row stride (for bottom-up image layouts) or a stride exceeding 65535 bytes. The bug was introduced in libpng 1.6.26 (October 2016) by casts added to silence compiler warnings on 16-bit systems. This vulnerability is fixed in 1.6.54.
CVSS 6.8 · Средний · EPSS 0,1% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
libpng
- Версии
- < 1.6.54: Затронуто
Нет опубликованного исправления
libpng1.6 Debian:12
- Версии
- 1.6.39-2
- 1.6.39-2+deb12u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.39-2+deb12u2
Обновитесь до 1.6.39-2+deb12u2
libpng1.6 Debian:13
- Версии
- 1.6.48-1
- 1.6.48-1+deb13u1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.48-1+deb13u2
Обновитесь до 1.6.48-1+deb13u2
libpng1.6 Debian:14
- Версии
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- 1.6.51-1
- 1.6.52-1
- 1.6.53-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.54-1
Обновитесь до 1.6.54-1
libpng1.6 Ubuntu:Pro:18.04:LTS
- Версии
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- 1.6.34-1ubuntu0.18.04.2+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm2
Обновитесь до 1.6.34-1ubuntu0.18.04.2+esm2
libpng1.6 Ubuntu:Pro:20.04:LTS
- Версии
- 1.6.37-1
- 1.6.37-2
- 1.6.37-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm2
Обновитесь до 1.6.37-2ubuntu0.1~esm2
libpng1.6 Ubuntu:22.04:LTS
- Версии
- 1.6.37-3build4
- 1.6.37-3build5
- 1.6.37-3ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.37-3ubuntu0.3
Обновитесь до 1.6.37-3ubuntu0.3
libpng1.6 Ubuntu:24.04:LTS
- Версии
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- 1.6.43-5ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.43-5ubuntu0.3
Обновитесь до 1.6.43-5ubuntu0.3
libpng1.6 Ubuntu:25.10
- Версии
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1~exp1
- 1.6.50-1
- 1.6.50-1ubuntu0.1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.50-1ubuntu0.3
Обновитесь до 1.6.50-1ubuntu0.3
libpng1.6 Ubuntu:26.04:LTS
- Версии
- 1.6.50-1
- 1.6.51-1
- 1.6.53-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.54-1
Обновитесь до 1.6.54-1