p PatchFirst

CVE-2026-23643

CVE-2026-23643 · CakePHP PaginatorHelper::limitControl() vulnerable to reflected cross-site-scripting

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CakePHP is a rapid development framework for PHP. The PaginatorHelper::limitControl() method has a cross-site-scripting vulnerability via query string parameter manipulation. This issue has been fixed in 5.2.12 and 5.3.1.

CVSS 5.4 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: system · php

Затронутые продукты и версии

  • cakephp

    Версии
    • >= 5.2.10, < 5.2.12: Затронуто
    • >= 5.3.0, < 5.3.1: Затронуто

    Нет опубликованного исправления

  • cakephp/cakephp Packagist

    Версии
    • 5.2.10
    • 5.2.11
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.2.10, < 5.2.12

    Обновитесь до 5.2.12

  • cakephp/cakephp Packagist

    Версии
    • 5.3.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.3.0, < 5.3.1

    Обновитесь до 5.3.1

  • cakephp Ubuntu:16.04:LTS

    Версии
    • 2.7.2-1
    • 2.8.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • cakephp Ubuntu:20.04:LTS

    Версии
    • 2.10.11-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • cakephp Ubuntu:22.04:LTS

    Версии
    • 2.10.11-2.1
    • 2.10.24-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →