p PatchFirst

CVE-2026-23984

CVE-2026-23984 · Apache Superset: SQLLab Read-Only Bypass on PostgreSQL

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

An Improper Input Validation vulnerability exists in Apache Superset that allows an authenticated user with SQLLab access to bypass the read-only verification check when using a PostgreSQL database connection. While the system effectively blocks standard Data Manipulation Language (DML) statements (e.g., INSERT, UPDATE, DELETE) on read-only connections, it fails to detect them in specially crafted SQL statements. This issue affects Apache Superset: before 6.0.0. Users are recommended to upgrade to version 6.0.0, which fixes the issue.

CVSS 7.1 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • apache superset

    Версии
    • ≥ 0.0.0, < 6.0.0: Затронуто (semver)

    Обновитесь до 6.0.0

  • apache-superset PyPI

    Версии
    • 0.34.0
    • 0.34.1
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.37.2
    • 0.38.0
    • 0.38.1
    • 1.0.0
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.4.2
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 2.0.0
    • 2.0.1
    • 2.1.0
    • 2.1.1
    • 2.1.1rc1
    • 2.1.1rc2
    • 2.1.1rc3
    • 2.1.2
    • 2.1.3
    • 3.0.0
    • 3.0.0rc1
    • 3.0.0rc2
    • 3.0.0rc3
    • 3.0.0rc4
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.1.0rc1
    • 3.1.0rc2
    • 3.1.0rc3
    • 3.1.0rc4
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 4.0.0
    • 4.0.0rc1
    • 4.0.0rc2
    • 4.0.1
    • 4.0.2
    • 4.1.0
    • 4.1.0rc2
    • 4.1.0rc3
    • 4.1.0rc4
    • 4.1.1
    • 4.1.1rc1
    • 4.1.2
    • 4.1.2rc1
    • 4.1.3.post1
    • 4.1.3rc1
    • 4.1.3rc2
    • 4.1.4
    • 4.1.4rc1
    • 5.0.0
    • 5.0.0rc1
    • 5.0.0rc2
    • 5.0.0rc3
    • 5.0.0rc4
    • 6.0.0rc1
    • 6.0.0rc2
    • 6.0.0rc3
    • 6.0.0rc4
    Затронутые диапазоны версий
    • ECOSYSTEM: < 6.0.0

    Обновитесь до 6.0.0

Первоисточники

Проверьте свой сервер →