p PatchFirst

CVE-2026-25054

CVE-2026-25054 · n8n is Vulnerable to Stored Cross-Site Scripting via Markdown Rendering in Workflow UI

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

n8n is an open source workflow automation platform. Prior to versions 1.123.9 and 2.2.1, a Cross-Site Scripting (XSS) vulnerability existed in a markdown rendering component used in n8n's interface, including workflow sticky notes and other areas that support markdown content. An authenticated user with permission to create or modify workflows could abuse this to execute scripts with same-origin privileges when other users interact with a maliciously crafted workflow. This could lead to session hijacking and account takeover. This issue has been patched in versions 1.123.9 and 2.2.1.

CVSS 8.5 · Высокий · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • n8n

    Версии
    • < 1.123.9: Затронуто
    • < 2.2.1: Затронуто

    Нет опубликованного исправления

  • n8n npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 2.0.0, < 2.2.1

    Обновитесь до 2.2.1

  • n8n npm

    Затронутые диапазоны версий
    • SEMVER: < 1.123.9

    Обновитесь до 1.123.9

Первоисточники

Проверьте свой сервер →