p PatchFirst

CVE-2026-25640

CVE-2026-25640 · Pydantic AI affected by Stored XSS via Path Traversal in Web UI CDN URL

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Pydantic AI is a Python agent framework for building applications and workflows with Generative AI. From 1.34.0 to before 1.51.0, a path traversal vulnerability in the Pydantic AI web UI allows an attacker to serve arbitrary JavaScript in the context of the application by crafting a malicious URL. In affected versions, the CDN URL is constructed using a version query parameter from the request URL. This parameter is not validated, allowing path traversal sequences that cause the server to fetch and serve attacker-controlled HTML/JavaScript from an arbitrary source on the same CDN, instead of the legitimate chat UI package. If a victim clicks the link or visits it via an iframe, attacker-controlled code executes in their browser, enabling theft of chat history and other client-side data. This vulnerability only affects applications that use Agent.to_web to serve a chat interface and clai web to serve a chat interface from the CLI. These are typically run locally (on localhost), but may also be deployed on a remote server. This vulnerability is fixed in 1.51.0.

CVSS 7.1 · Высокий · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • pydantic-ai

    Версии
    • >= 1.34.0, < 1.51.0: Затронуто

    Нет опубликованного исправления

  • pydantic-ai PyPI

    Версии
    • 1.34.0
    • 1.35.0
    • 1.36.0
    • 1.37.0
    • 1.38.0
    • 1.39.0
    • 1.39.1
    • 1.40.0
    • 1.41.0
    • 1.42.0
    • 1.43.0
    • 1.44.0
    • 1.46.0
    • 1.47.0
    • 1.48.0
    • 1.49.0
    • 1.50.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.34.0, < 1.51.0

    Обновитесь до 1.51.0

  • pydantic-ai-slim PyPI

    Версии
    • 1.34.0
    • 1.35.0
    • 1.36.0
    • 1.37.0
    • 1.38.0
    • 1.39.0
    • 1.39.1
    • 1.40.0
    • 1.41.0
    • 1.42.0
    • 1.43.0
    • 1.44.0
    • 1.46.0
    • 1.47.0
    • 1.48.0
    • 1.49.0
    • 1.50.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 1.34.0, < 1.51.0

    Обновитесь до 1.51.0

Первоисточники

Проверьте свой сервер →