CVE-2026-25646
CVE-2026-25646 · LIBPNG has a heap buffer overflow in png_set_quantize
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
На странице показана часть фактов из источников. Полное описание и список затронутых версий приведены в связанных бюллетенях.
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to 1.6.55, an out-of-bounds read vulnerability exists in the png_set_quantize() API function. When the function is called with no histogram and the number of colors in the palette is more than twice the maximum supported by the user's display, certain palettes will cause the function to enter into an infinite loop that reads past the end of an internal heap-allocated buffer. The images that trigger this vulnerability are valid per the PNG specification. This vulnerability is fixed in 1.6.55.
CVSS 8.3 · Высокий · EPSS 1,1% · Есть исправление
- Опубликовано
- Обновлено
Стек: system
Затронутые продукты и версии
libpng
- Версии
- < 1.6.55: Затронуто
Нет опубликованного исправления
libpng1.6 Debian:12
- Версии
- 1.6.39-2
- 1.6.39-2+deb12u1
- 1.6.39-2+deb12u2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.39-2+deb12u3
Обновитесь до 1.6.39-2+deb12u3
libpng1.6 Debian:13
- Версии
- 1.6.48-1
- 1.6.48-1+deb13u1
- 1.6.48-1+deb13u2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.48-1+deb13u3
Обновитесь до 1.6.48-1+deb13u3
libpng1.6 Debian:14
- Версии
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- 1.6.51-1
- 1.6.52-1
- 1.6.53-1
- 1.6.54-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.55-1
Обновитесь до 1.6.55-1
libpng Ubuntu:Pro:14.04:LTS
- Версии
- 1.2.49-4ubuntu1
- 1.2.49-5ubuntu1
- 1.2.50-1ubuntu1
- 1.2.50-1ubuntu2
- 1.2.50-1ubuntu2.14.04.1
- 1.2.50-1ubuntu2.14.04.2
- 1.2.50-1ubuntu2.14.04.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.2.50-1ubuntu2.14.04.3+esm1
Обновитесь до 1.2.50-1ubuntu2.14.04.3+esm1
libpng Ubuntu:Pro:16.04:LTS
- Версии
- 1.2.51-0ubuntu3
- 1.2.54-1
- 1.2.54-1ubuntu1
- 1.2.54-1ubuntu1.1
- 1.2.54-1ubuntu1.1+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.2.54-1ubuntu1.1+esm2
Обновитесь до 1.2.54-1ubuntu1.1+esm2
libpng1.6 Ubuntu:Pro:16.04:LTS
- Версии
- 1.6.20-2
- 1.6.20-2ubuntu0.1~esm1
- 1.6.20-2ubuntu0.1~esm2
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm3
Обновитесь до 1.6.20-2ubuntu0.1~esm3
libpng1.6 Ubuntu:Pro:18.04:LTS
- Версии
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- 1.6.34-1ubuntu0.18.04.2+esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm2
Обновитесь до 1.6.34-1ubuntu0.18.04.2+esm2
libpng1.6 Ubuntu:Pro:20.04:LTS
- Версии
- 1.6.37-1
- 1.6.37-2
- 1.6.37-2ubuntu0.1~esm1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm2
Обновитесь до 1.6.37-2ubuntu0.1~esm2
libpng1.6 Ubuntu:22.04:LTS
- Версии
- 1.6.37-3build4
- 1.6.37-3build5
- 1.6.37-3ubuntu0.1
- 1.6.37-3ubuntu0.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.37-3ubuntu0.4
Обновитесь до 1.6.37-3ubuntu0.4
libpng1.6 Ubuntu:24.04:LTS
- Версии
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- 1.6.43-5ubuntu0.1
- 1.6.43-5ubuntu0.3
- 1.6.43-5ubuntu0.4
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.43-5ubuntu0.5
Обновитесь до 1.6.43-5ubuntu0.5
libpng1.6 Ubuntu:25.10
- Версии
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1~exp1
- 1.6.50-1
- 1.6.50-1ubuntu0.1
- 1.6.50-1ubuntu0.3
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.50-1ubuntu0.4
Обновитесь до 1.6.50-1ubuntu0.4
libpng1.6 Ubuntu:26.04:LTS
- Версии
- 1.6.50-1
- 1.6.51-1
- 1.6.53-1
- 1.6.54-1
- Затронутые диапазоны версий
- ECOSYSTEM: < 1.6.55-1
Обновитесь до 1.6.55-1
Первоисточники
- https://github.com/pnggroup/libpng/security/advisories/GHSA-g8hp-mq4h-rqm3
- https://github.com/pnggroup/libpng/commit/01d03b8453eb30ade759cd45c707e5a1c7277d88
- http://www.openwall.com/lists/oss-security/2026/02/09/7
- https://access.redhat.com/security/cve/CVE-2026-25646
- https://bugzilla.redhat.com/show_bug.cgi?id=2438542
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-25646.json
- https://access.redhat.com/errata/RHSA-2026:4756
- https://access.redhat.com/errata/RHSA-2026:7032
- https://access.redhat.com/errata/RHSA-2026:12274
- https://access.redhat.com/errata/RHSA-2026:7239
- https://access.redhat.com/errata/RHSA-2026:15087
- https://access.redhat.com/errata/RHSA-2026:14773
- https://access.redhat.com/errata/RHSA-2026:10097
- https://access.redhat.com/errata/RHSA-2026:17596
- https://access.redhat.com/errata/RHSA-2026:6553
- https://access.redhat.com/errata/RHSA-2026:7243
- https://access.redhat.com/errata/RHSA-2026:3577
- https://access.redhat.com/errata/RHSA-2026:3551
- https://access.redhat.com/errata/RHSA-2026:6445
- https://access.redhat.com/errata/RHSA-2026:6439
- https://access.redhat.com/errata/RHSA-2026:7035
- https://access.redhat.com/errata/RHSA-2026:6466
- https://access.redhat.com/errata/RHSA-2026:7036
- https://nvd.nist.gov/vuln/detail/CVE-2026-25646