CVE-2026-26929
CVE-2026-26929 · Apache Airflow: Wildcard DagVersion Listing Bypasses Per‑DAG RBAC and Leaks Metadata
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Apache Airflow versions 3.0.0 through 3.1.7 FastAPI DagVersion listing API does not apply per-DAG authorization filtering when the request is made with dag_id set to "~" (wildcard for all DAGs). As a result, version metadata of DAGs that the requester is not authorized to access is returned. Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
CVSS 6.5 · Средний · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Стек: python
Затронутые продукты и версии
apache airflow
- Версии
- ≥ 3.0.0, < 3.1.8: Затронуто (semver)
Обновитесь до 3.1.8
apache-airflow PyPI
- Версии
- 3.0.0
- 3.0.1
- 3.0.1rc1
- 3.0.2
- 3.0.2rc1
- 3.0.2rc2
- 3.0.3
- 3.0.3rc1
- 3.0.3rc2
- 3.0.3rc3
- 3.0.3rc4
- 3.0.3rc5
- 3.0.3rc6
- 3.0.4
- 3.0.4rc1
- 3.0.4rc2
- 3.0.5
- 3.0.5rc1
- 3.0.5rc2
- 3.0.5rc3
- 3.0.6
- 3.0.6rc1
- 3.0.6rc2
- 3.1.0
- 3.1.0b1
- 3.1.0b2
- 3.1.0rc1
- 3.1.0rc2
- 3.1.1
- 3.1.1rc1
- 3.1.1rc2
- 3.1.2
- 3.1.2rc1
- 3.1.2rc2
- 3.1.3
- 3.1.3rc1
- 3.1.4
- 3.1.4rc1
- 3.1.4rc2
- 3.1.5
- 3.1.5rc1
- 3.1.6
- 3.1.6rc1
- 3.1.7
- 3.1.7rc1
- 3.1.7rc2
- 3.1.8rc1
- 3.1.8rc2
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.0.0, < 3.1.8
Обновитесь до 3.1.8