p PatchFirst

CVE-2026-27971

CVE-2026-27971 · Qwik affected by unauthenticated RCE via server$ Deserialization

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Qwik is a performance focused javascript framework. qwik <=1.19.0 is vulnerable to RCE due to an unsafe deserialization vulnerability in the server$ RPC mechanism that allows any unauthenticated user to execute arbitrary code on the server with a single HTTP request. Affects any deployment where require() is available at runtime. This vulnerability is fixed in 1.19.1.

CVSS 9.2 · Критический · EPSS 5,5% · Публичный эксплойт · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • qwik

    Версии
    • < 1.19.1: Затронуто

    Нет опубликованного исправления

  • @builder.io/qwik npm

    Затронутые диапазоны версий
    • SEMVER: < 1.19.1

    Обновитесь до 1.19.1

Первоисточники

Проверьте свой сервер →