p PatchFirst

CVE-2026-28498

CVE-2026-28498 · Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to version 1.6.9, a library-level vulnerability was identified in the Authlib Python library concerning the validation of OpenID Connect (OIDC) ID Tokens. Specifically, the internal hash verification logic (_verify_hash) responsible for validating the at_hash (Access Token Hash) and c_hash (Authorization Code Hash) claims exhibits a fail-open behavior when encountering an unsupported or unknown cryptographic algorithm. This flaw allows an attacker to bypass mandatory integrity protections by supplying a forged ID Token with a deliberately unrecognized alg header parameter. The library intercepts the unsupported state and silently returns True (validation passed), inherently violating fundamental cryptographic design principles and direct OIDC specifications. This issue has been patched in version 1.6.9.

CVSS 8.2 · Высокий · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • authlib

    Версии
    • < 1.6.9: Затронуто

    Нет опубликованного исправления

  • python-authlib Debian:12

    Версии
    • 1.2.0-1
    • 1.2.0-1+deb12u1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.2.0-1+deb12u2

    Обновитесь до 1.2.0-1+deb12u2

  • python-authlib Debian:13

    Версии
    • 1.6.0-1
    • 1.6.0-1+deb13u1
    • 1.6.1-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    • 1.6.6-1
    • 1.6.7-1
    • 1.6.8-1
    • 1.6.9-1
    • 1.7.0-1
    • 1.7.2-1
    • 1.7.2-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • python-authlib Debian:14

    Версии
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.3-1
    • 1.6.4-1
    • 1.6.5-1
    • 1.6.6-1
    • 1.6.7-1
    • 1.6.8-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.9-1

    Обновитесь до 1.6.9-1

  • authlib PyPI

    Версии
    • 0.1
    • 0.10
    • 0.11
    • 0.12
    • 0.12.1
    • 0.13
    • 0.14
    • 0.14.1
    • 0.14.2
    • 0.14.3
    • 0.15
    • 0.15.1
    • 0.15.2
    • 0.15.3
    • 0.15.4
    • 0.15.5
    • 0.15.6
    • 0.1rc0
    • 0.2
    • 0.2.1
    • 0.3
    • 0.4
    • 0.4.1
    • 0.5
    • 0.5.1
    • 0.6
    • 0.7
    • 0.8
    • 0.9
    • 1.0.0
    • 1.0.0a1
    • 1.0.0a2
    • 1.0.0b1
    • 1.0.0b2
    • 1.0.0rc1
    • 1.0.1
    • 1.1.0
    • 1.2.0
    • 1.2.1
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.1
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • 1.6.7
    • 1.6.8
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.9

    Обновитесь до 1.6.9

  • python-authlib Ubuntu:Pro:22.04:LTS

    Версии
    • 0.15.4-1
    • 0.15.5-1
    • 0.15.5-1ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.15.5-1ubuntu0.1~esm2

    Обновитесь до 0.15.5-1ubuntu0.1~esm2

  • python-authlib Ubuntu:Pro:24.04:LTS

    Версии
    • 1.2.1-1
    • 1.3.0-1
    • 1.3.0-1ubuntu0.1~esm1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.3.0-1ubuntu0.1~esm2

    Обновитесь до 1.3.0-1ubuntu0.1~esm2

  • python-authlib Ubuntu:25.10

    Версии
    • 1.5.1-1
    • 1.5.2-1
    • 1.6.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • python-authlib Ubuntu:26.10

    Версии
    • 1.6.7-1
    • 1.7.2-1
    • 1.7.2-2
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • python-authlib Ubuntu:Pro:26.04:LTS

    Версии
    • 1.6.0-1
    • 1.6.5-1
    • 1.6.6-1
    • 1.6.7-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.7-1ubuntu0.1~esm1

    Обновитесь до 1.6.7-1ubuntu0.1~esm1

Первоисточники

Проверьте свой сервер →