p PatchFirst

CVE-2026-29129

CVE-2026-29129 · Apache Tomcat: TLS cipher order is not preserved

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Configured cipher preference order not preserved vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.16 through 11.0.18, from 10.1.51 through 10.1.52, from 9.0.114 through 9.0.115. Users are recommended to upgrade to version 11.0.20, 10.1.53 or 9.0.116, which fix the issue.

CVSS 7.5 · Высокий · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: system

Затронутые продукты и версии

  • apache tomcat

    Версии
    • ≥ 11.0.16, ≤ 11.0.18: Затронуто (semver)
    • ≥ 10.1.51, ≤ 10.1.52: Затронуто (semver)
    • ≥ 9.0.114, ≤ 9.0.115: Затронуто (semver)

    Нет опубликованного исправления

  • tomcat10 Debian:12

    Версии
    • 10.1.10-1
    • 10.1.13-1
    • 10.1.14-1
    • 10.1.15-1
    • 10.1.16-1
    • 10.1.20-1
    • 10.1.23-1
    • 10.1.25-1
    • 10.1.25-1~bpo12+1
    • 10.1.25-2
    • 10.1.30-1
    • 10.1.30-1~bpo12+1
    • 10.1.31-1
    • 10.1.33-1
    • 10.1.33-1~bpo12+1
    • 10.1.34-0+deb12u1
    • 10.1.34-0+deb12u2
    • 10.1.34-1
    • 10.1.35-1
    • 10.1.40-1
    • 10.1.40-1~bpo12+1
    • 10.1.46-1
    • 10.1.52-1
    • 10.1.52-1~deb12u1
    • 10.1.52-1~deb13u1
    • 10.1.52-2
    • 10.1.54-1
    • 10.1.6-1
    • 10.1.6-1+deb12u1
    • 10.1.6-1+deb12u2
    • 10.1.7-1
    • 10.1.8-1
    • 10.1.9-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.55-1~deb12u1

    Обновитесь до 10.1.55-1~deb12u1

  • tomcat10 Debian:13

    Версии
    • 10.1.40-1
    • 10.1.46-1
    • 10.1.52-1
    • 10.1.52-1~deb12u1
    • 10.1.52-1~deb13u1
    • 10.1.52-2
    • 10.1.54-1
    • 10.1.55-1~deb12u1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.55-1~deb13u1

    Обновитесь до 10.1.55-1~deb13u1

  • tomcat10 Debian:14

    Версии
    • 10.1.40-1
    • 10.1.46-1
    • 10.1.52-1
    • 10.1.52-1~deb12u1
    • 10.1.52-1~deb13u1
    • 10.1.52-2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 10.1.54-1

    Обновитесь до 10.1.54-1

  • tomcat11 Debian:13

    Версии
    • 11.0.11-1
    • 11.0.15-1
    • 11.0.15-1~deb13u1
    • 11.0.18-1
    • 11.0.21-1
    • 11.0.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 11.0.22-1~deb13u1

    Обновитесь до 11.0.22-1~deb13u1

  • tomcat11 Debian:14

    Версии
    • 11.0.11-1
    • 11.0.15-1
    • 11.0.15-1~deb13u1
    • 11.0.18-1
    • 11.0.6-1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 11.0.21-1

    Обновитесь до 11.0.21-1

  • tomcat9 Debian:12

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat9 Debian:13

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat9 Debian:14

    Затронутые диапазоны версий
    • ECOSYSTEM: < 9.0.70-2

    Обновитесь до 9.0.70-2

  • tomcat9 Ubuntu:26.04:LTS

    Версии
    • 9.0.95-1ubuntu1
    • 9.0.111-1
    • 9.0.115-1
    • 9.0.115-1ubuntu0.1
    • 9.0.118-1~26.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • tomcat11 Ubuntu:26.04:LTS

    Версии
    • 11.0.6-1
    • 11.0.11-1
    • 11.0.15-1
    • 11.0.18-1
    • 11.0.18-1ubuntu0.1~esm1
    • 11.0.22-2ubuntu2~26.04.1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

Первоисточники

Проверьте свой сервер →