p PatchFirst

CVE-2026-29176

CVE-2026-29176 · Craft Commerce has Stored XSS in Inventory Location Name

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Craft Commerce is an ecommerce platform for Craft CMS. Prior to 5.5.3, A stored XSS vulnerability exists in the Commerce Settings - Inventory Locations page. The Name field is rendered without proper HTML escaping, allowing an attacker to execute arbitrary JavaScript. This XSS triggers when an administrator (or user with product editing permissions) creates or edits a variant product. This vulnerability is fixed in 5.5.3.

CVSS 4.8 · Средний · EPSS 0,2% · Есть исправление

Опубликовано
Обновлено

Стек: php

Затронутые продукты и версии

  • commerce

    Версии
    • >= 4.0.0 < 4.10.2: Затронуто
    • >= 5.0.0 < 5.5.3: Затронуто

    Нет опубликованного исправления

  • craftcms/commerce Packagist

    Версии
    • 5.0.0
    • 5.0.1
    • 5.0.10
    • 5.0.10.1
    • 5.0.11
    • 5.0.11.1
    • 5.0.12
    • 5.0.12.1
    • 5.0.12.2
    • 5.0.13
    • 5.0.14
    • 5.0.15
    • 5.0.16
    • 5.0.16.1
    • 5.0.16.2
    • 5.0.17
    • 5.0.18
    • 5.0.19
    • 5.0.2
    • 5.0.3
    • 5.0.4
    • 5.0.5
    • 5.0.6
    • 5.0.7
    • 5.0.8
    • 5.0.9
    • 5.1.0
    • 5.1.0-beta.1
    • 5.1.0-beta.2
    • 5.1.0-beta.3
    • 5.1.0.1
    • 5.1.1
    • 5.1.2
    • 5.1.3
    • 5.1.4
    • 5.2.0
    • 5.2.1
    • 5.2.10
    • 5.2.11
    • 5.2.12
    • 5.2.12.1
    • 5.2.2
    • 5.2.2.1
    • 5.2.3
    • 5.2.4
    • 5.2.5
    • 5.2.6
    • 5.2.7
    • 5.2.8
    • 5.2.9
    • 5.2.9.1
    • 5.3.0
    • 5.3.0.1
    • 5.3.0.2
    • 5.3.1
    • 5.3.10
    • 5.3.11
    • 5.3.12
    • 5.3.13
    • 5.3.2
    • 5.3.2.1
    • 5.3.2.2
    • 5.3.3
    • 5.3.4
    • 5.3.5
    • 5.3.6
    • 5.3.7
    • 5.3.8
    • 5.3.9
    • 5.4.0
    • 5.4.1
    • 5.4.1.1
    • 5.4.10
    • 5.4.2
    • 5.4.3
    • 5.4.4
    • 5.4.5
    • 5.4.5.1
    • 5.4.6
    • 5.4.7
    • 5.4.7.1
    • 5.4.8
    • 5.4.9
    • 5.5.0
    • 5.5.0.1
    • 5.5.1
    • 5.5.2
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.0.0, < 5.5.3

    Обновитесь до 5.5.3

Первоисточники

Проверьте свой сервер →