CVE-2026-30946
CVE-2026-30946 · Parse Server affected by denial-of-service via unbounded query complexity in REST and GraphQL API
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior 9.5.2-alpha.2 and 8.6.15, an unauthenticated attacker can exhaust Parse Server resources (CPU, memory, database connections) through crafted queries that exploit the lack of complexity limits in the REST and GraphQL APIs. All Parse Server deployments using the REST or GraphQL API are affected. This vulnerability is fixed in 9.5.2-alpha.2 and 8.6.15.
CVSS 8.7 · Высокий · EPSS 0,6% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
parse-server
- Версии
- < 8.6.15: Затронуто
- >= 9.0.0 < 9.5.2-alpha.2: Затронуто
Нет опубликованного исправления
parse-server npm
- Затронутые диапазоны версий
- SEMVER: < 8.6.15
Обновитесь до 8.6.15
parse-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 9.0.0, < 9.5.2-alpha.2
Обновитесь до 9.5.2-alpha.2