CVE-2026-30949
CVE-2026-30949 · Parse Server is missing audience validation in Keycloak authentication adapter
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.5 and 8.6.18, the Keycloak authentication adapter does not validate the azp (authorized party) claim of Keycloak access tokens against the configured client-id. A valid access token issued by the same Keycloak realm for a different client application can be used to authenticate as any user on the Parse Server that uses the Keycloak adapter. This enables cross-application account takeover in multi-client Keycloak realms. All Parse Server deployments that use the Keycloak authentication adapter with a Keycloak realm that has multiple client applications are affected. This vulnerability is fixed in 9.5.2-alpha.5 and 8.6.18.
CVSS 7.6 · Высокий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
parse-server
- Версии
- >= 9.0.0 < 9.5.2-alpha.5: Затронуто
- < 8.6.18: Затронуто
Нет опубликованного исправления
parse-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 9.0.0, < 9.5.2-alpha.5
Обновитесь до 9.5.2-alpha.5
parse-server npm
- Затронутые диапазоны версий
- SEMVER: < 8.6.18
Обновитесь до 8.6.18