CVE-2026-30962
CVE-2026-30962 · Parse Server has a protected fields bypass via logical query operators
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.5.2-alpha.6 and 8.6.19, the validation for protected fields only checks top-level query keys. By wrapping a query constraint on a protected field inside a logical operator, the check is bypassed entirely. This allows any authenticated user to query on protected fields to extract field values. All Parse Server deployments have default protected fields and are vulnerable. This vulnerability is fixed in 9.5.2-alpha.6 and 8.6.19.
CVSS 7.1 · Высокий · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
parse-server
- Версии
- >= 9.0.0 < 9.5.2-alpha.6: Затронуто
- < 8.6.19: Затронуто
Нет опубликованного исправления
parse-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 9.0.0, < 9.5.2-alpha.6
Обновитесь до 9.5.2-alpha.6
parse-server npm
- Затронутые диапазоны версий
- SEMVER: < 8.6.19
Обновитесь до 8.6.19