CVE-2026-31841
CVE-2026-31841 · Raw exposure of database statements in Hyperterse MCP search tool
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Hyperterse is a tool-first MCP framework for building AI-ready backend surfaces from declarative config. Prior to v2.2.0, the search tool allows LLMs to search for tools using natural language. While returning results, Hyperterse also returned the raw SQL queries, exposing statements which were supposed to be executed under the hood, and protected from being displayed publicly. This issue has been fixed as of v2.2.0.
CVSS 6.5 · Средний · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
hyperterse
- Версии
- >= 2.0.0, < 2.2.0: Затронуто
Нет опубликованного исправления
hyperterse npm
- Затронутые диапазоны версий
- SEMVER: ≥ 2.0.0, < 2.2.0
Обновитесь до 2.2.0