p PatchFirst

CVE-2026-32732

CVE-2026-32732 · XSS in @leanprover/unicode-input-component

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Lean 4 VS Code Extension is a Visual Studio Code extension for the Lean 4 proof assistant. Projects that use @leanprover/unicode-input-component are vulnerable to an XSS exploit in 0.1.9 of the package and lower. The component re-inserted text in the input element back into the input element as unescaped HTML. The issue has been resolved in 0.2.0.

CVSS 0.0 · Низкий · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • vscode-lean4

    Версии
    • < 0.2.0: Затронуто

    Нет опубликованного исправления

  • @leanprover/unicode-input-component npm

    Затронутые диапазоны версий
    • SEMVER: < 0.2.0

    Обновитесь до 0.2.0

Первоисточники

Проверьте свой сервер →