p PatchFirst

CVE-2026-32813

CVE-2026-32813 · Admidio: Second-Order SQL Injection via List Configuration (lsc_special_field, lsc_sort, lsc_filter)

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

Admidio is an open-source user management solution. Versions 5.0.6 and below are vulnerable to arbitrary SQL Injection through the MyList configuration feature. The MyList configuration feature lets authenticated users define custom list column layouts, storing user-supplied column names, sort directions, and filter conditions in the adm_list_columns table via prepared statements. However, these stored values are later read back and interpolated directly into dynamically constructed SQL queries without sanitization or parameterization, creating a classic second-order SQL injection vulnerability (safe write, unsafe read). An attacker can exploit this to inject arbitrary SQL, potentially reading, modifying, or deleting any data in the database and achieving full database compromise. This issue has been fixed in version 5.0.7.

CVSS 8.0 · Высокий · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: php

Затронутые продукты и версии

  • admidio

    Версии
    • < 5.0.7: Затронуто

    Нет опубликованного исправления

  • admidio/admidio Packagist

    Версии
    • 4.1.0
    • 4.1.3
    • v4.2-Beta.1
    • v4.2-Beta.2
    • v4.2-Beta.3
    • v4.2.0
    • v4.2.1
    • v4.2.10
    • v4.2.11
    • v4.2.12
    • v4.2.13
    • v4.2.14
    • v4.2.2
    • v4.2.3
    • v4.2.4
    • v4.2.5
    • v4.2.6
    • v4.2.7
    • v4.2.8
    • v4.2.9
    • v4.3-Beta.1
    • v4.3-Beta.3
    • v4.3-Beta.4
    • v4.3-Beta.5
    • v4.3.0
    • v4.3.1
    • v4.3.10
    • v4.3.11
    • v4.3.12
    • v4.3.13
    • v4.3.14
    • v4.3.15
    • v4.3.16
    • v4.3.17
    • v4.3.2
    • v4.3.3
    • v4.3.4
    • v4.3.5
    • v4.3.6
    • v4.3.7
    • v4.3.8
    • v4.3.9
    • v5.0-Beta.1
    • v5.0-Beta.2
    • v5.0-Beta.3
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.0.4
    • v5.0.5
    • v5.0.6
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.0.7

    Обновитесь до 5.0.7

Первоисточники

Проверьте свой сервер →