p PatchFirst

CVE-2026-32874

CVE-2026-32874 · UltraJSON has a Memory Leak parsing large integers allows DoS

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. Versions 5.4.0 through 5.11.0 contain an accumulating memory leak in JSON parsing large (outside of the range [-2^63, 2^64 - 1]) integers. The leaked memory is a copy of the string form of the integer plus an additional NULL byte. The leak occurs irrespective of whether the integer parses successfully or is rejected due to having more than sys.get_int_max_str_digits() digits, meaning that any sized leak per malicious JSON can be achieved provided that there is no limit on the overall size of the payload. Any service that calls ujson.load()/ujson.loads()/ujson.decode() on untrusted inputs is affected and vulnerable to denial of service attacks. This issue has been fixed in version 5.12.0.

CVSS 7.5 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: system · python

Затронутые продукты и версии

  • ultrajson

    Версии
    • >= 5.4.0, < 5.12.0: Затронуто

    Нет опубликованного исправления

  • ujson Debian:12

    Версии
    • 5.10.0-1
    • 5.11.0-1
    • 5.11.0-2
    • 5.11.0-3
    • 5.13.0-1
    • 5.7.0-1
    • 5.8.0-1
    • 5.9.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • ujson Debian:13

    Версии
    • 5.10.0-1
    • 5.11.0-1
    • 5.11.0-2
    • 5.11.0-3
    • 5.13.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • ujson Debian:14

    Версии
    • 5.10.0-1
    • 5.11.0-1
    • 5.11.0-2
    • 5.11.0-3
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.13.0-1

    Обновитесь до 5.13.0-1

  • ujson PyPI

    Версии
    • 5.10.0
    • 5.11.0
    • 5.4.0
    • 5.5.0
    • 5.6.0
    • 5.7.0
    • 5.8.0
    • 5.9.0
    Затронутые диапазоны версий
    • ECOSYSTEM: ≥ 5.4.0, < 5.12.0

    Обновитесь до 5.12.0

  • ujson Ubuntu:Pro:24.04:LTS

    Версии
    • 5.8.0-1
    • 5.8.0-1build1
    • 5.9.0-1
    • 5.9.0-1build1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.9.0-1ubuntu0.1~esm1

    Обновитесь до 5.9.0-1ubuntu0.1~esm1

  • ujson Ubuntu:25.10

    Версии
    • 5.10.0-1build2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.10.0-1ubuntu0.1

    Обновитесь до 5.10.0-1ubuntu0.1

  • ujson Ubuntu:26.10

    Версии
    • 5.11.0-3build1
    • 5.13.0-1
    Затронутые диапазоны версий
    • ECOSYSTEM: (−∞, +∞)

    Нет опубликованного исправления

  • ujson Ubuntu:26.04:LTS

    Версии
    • 5.10.0-1build2
    • 5.10.0-1build3
    • 5.11.0-3
    • 5.11.0-3build1
    Затронутые диапазоны версий
    • ECOSYSTEM: < 5.11.0-3ubuntu0.1

    Обновитесь до 5.11.0-3ubuntu0.1

Первоисточники

Проверьте свой сервер →