CVE-2026-33527
CVE-2026-33527 · Parse Server: Session update endpoint allows overwriting server-generated session fields
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.57 and 9.6.0-alpha.48, an authenticated user can overwrite server-generated session fields such as expiresAt and createdWith when updating their own session via the REST API. This allows bypassing the server's configured session lifetime policy, making a session effectively permanent. This issue has been patched in versions 8.6.57 and 9.6.0-alpha.48.
CVSS 5.3 · Средний · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
parse-server
- Версии
- < 8.6.57: Затронуто
- >= 9.0.0, < 9.6.0-alpha.48: Затронуто
Нет опубликованного исправления
parse-server npm
- Затронутые диапазоны версий
- SEMVER: ≥ 9.0.0, < 9.6.0-alpha.48
Обновитесь до 9.6.0-alpha.48
parse-server npm
- Затронутые диапазоны версий
- SEMVER: < 8.6.57
Обновитесь до 8.6.57
Первоисточники
- https://github.com/parse-community/parse-server/security/advisories/GHSA-jc39-686j-wp6q
- https://github.com/parse-community/parse-server/pull/10263
- https://github.com/parse-community/parse-server/pull/10264
- https://github.com/parse-community/parse-server/commit/26b628c8fb3cc79ea955374769eebcff6f8a8a73
- https://github.com/parse-community/parse-server/commit/ea68fc0b22a6056c9675149469ff57817f7cf984
- https://nvd.nist.gov/vuln/detail/CVE-2026-33527