CVE-2026-33804
CVE-2026-33804 · @fastify/middie vulnerable to middleware bypass via deprecated ignoreDuplicateSlashes option
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
@fastify/middie versions 9.3.1 and earlier are vulnerable to middleware bypass when the deprecated Fastify ignoreDuplicateSlashes option is enabled. The middleware path matching logic does not account for duplicate slash normalization performed by Fastify's router, allowing requests with duplicate slashes to bypass middleware authentication and authorization checks. This only affects applications using the deprecated ignoreDuplicateSlashes option. Upgrade to @fastify/middie 9.3.2 to fix this issue. There are no workarounds other than disabling the ignoreDuplicateSlashes option.
CVSS 7.4 · Высокий · EPSS 0,3% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
@fastify/middie
- Версии
- ≥ 0, < 9.3.2: Затронуто (semver)
- 9.3.2: Не затронуто (semver)
Обновитесь до 9.3.2
@fastify/middie npm
- Затронутые диапазоны версий
- SEMVER: < 9.3.2
Обновитесь до 9.3.2