p PatchFirst

CVE-2026-33807

CVE-2026-33807 · @fastify/express vulnerable to middleware path doubling causing authentication bypass in child plugin scopes

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

@fastify/express v4.0.4 and earlier contains a path handling bug in the onRegister function that causes middleware paths to be doubled when inherited by child plugins. When a child plugin is registered with a prefix that matches a middleware path, the middleware path is prefixed a second time, causing it to never match incoming requests. This results in complete bypass of Express middleware security controls, including authentication, authorization, and rate limiting, for all routes defined within affected child plugin scopes. No special configuration or request crafting is required. Upgrade to @fastify/express v4.0.5 or later.

CVSS 9.1 · Критический · EPSS 0,4% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • @fastify/express

    Версии
    • ≥ 0, < 4.0.5: Затронуто (semver)
    • 4.0.5: Не затронуто (semver)

    Обновитесь до 4.0.5

  • @fastify/express npm

    Затронутые диапазоны версий
    • SEMVER: < 4.0.5

    Обновитесь до 4.0.5

Первоисточники

Проверьте свой сервер →