p PatchFirst

CVE-2026-34052

CVE-2026-34052 · LTI JupyterHub Authenticator: Unbounded Memory Growth via Nonce Storage (Denial of Service)

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.

CVSS 5.9 · Средний · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: python

Затронутые продукты и версии

  • ltiauthenticator

    Версии
    • < 1.6.3: Затронуто

    Нет опубликованного исправления

  • jupyterhub-ltiauthenticator PyPI

    Версии
    • 0.1
    • 0.2
    • 0.3
    • 0.4.0
    • 1.0.0
    • 1.1.0
    • 1.2.0
    • 1.3.0
    • 1.4.0
    • 1.5.0
    • 1.5.1
    • 1.6.0
    • 1.6.1
    • 1.6.2
    Затронутые диапазоны версий
    • ECOSYSTEM: < 1.6.3

    Обновитесь до 1.6.3

Первоисточники

Проверьте свой сервер →