p PatchFirst

CVE-2026-34077

CVE-2026-34077 · React Router vulnerable to Denial of Service via reflected user input in single-fetch

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

React Router is a router for React. In versions 7.7.0 through 7.13.1, when using React Router's unstable React Server Components (RSC) APIs, there is a potential client-side Cross-Site Scripting (XSS) vulnerability in the RSC redirect handling if redirects come from untrusted sources. This does not impact applications that are not using the unstable RSC APIs in React Router. This is patched in version 7.13.2.

CVSS 7.5 · Высокий · EPSS 0,3% · Есть исправление

Опубликовано
Обновлено

Стек: node

Затронутые продукты и версии

  • react-router

    Версии
    • >= 7.0.0, < 7.14.0: Затронуто

    Нет опубликованного исправления

  • turbo-stream

    Версии
    • < 3.0.0: Затронуто

    Нет опубликованного исправления

  • react-router npm

    Затронутые диапазоны версий
    • SEMVER: ≥ 7.0.0, < 7.14.0

    Обновитесь до 7.14.0

  • turbo-stream npm

    Затронутые диапазоны версий
    • SEMVER: < 3.0.0

    Обновитесь до 3.0.0

Первоисточники

Проверьте свой сервер →