CVE-2026-34543
CVE-2026-34543 · OpenEXR: Heap information disclosure in PXR24 decompression via unchecked decompressed size (undo_pxr24_impl)
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From version 3.4.0 to before version 3.4.8, sensitive information from heap memory may be leaked through the decoded pixel data (information disclosure). This occurs under default settings; simply reading a malicious EXR file is sufficient to trigger the issue, without any user interaction. This issue has been patched in version 3.4.8.
CVSS 8.7 · Высокий · EPSS 0,5% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
openexr
- Версии
- >= 3.4.0, < 3.4.8: Затронуто
Нет опубликованного исправления
openexr Debian:12
- Версии
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
openexr Debian:13
- Версии
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
openexr Debian:14
- Версии
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.4.14-0.1
Обновитесь до 3.4.14-0.1
openexr PyPI
- Версии
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.4.0, < 3.4.8
Обновитесь до 3.4.8
openexr PyPI
- Версии
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.3.0, ≤ 3.3.8
Нет опубликованного исправления
openexr PyPI
- Версии
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.2.0, ≤ 3.2.6
Нет опубликованного исправления
openexr PyPI
- Версии
- 3.2.10
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- 3.3.0
- 3.3.1
- 3.3.10
- 3.3.11
- 3.3.12
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.3.9
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.2.0, < 3.4.8
Обновитесь до 3.4.8
openexr Ubuntu:26.10
- Версии
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-vc68-257w-m432
- https://github.com/AcademySoftwareFoundation/openexr/commit/5f6d0aaa9e43802917af7db90f181e88e083d3b8
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.8
- https://nvd.nist.gov/vuln/detail/CVE-2026-34543