p PatchFirst

CVE-2026-34572

CVE-2026-34572 · CI4MS: Account Deactivation Module Full Persistent Unauthorized Access for All‑Roles via Improper Session Invalidation (Logic Flaw)

Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.

CI4MS is a CodeIgniter 4-based CMS skeleton that delivers a production-ready, modular architecture with RBAC authorization and theme support. Prior to version 0.31.0.0, the application fails to immediately revoke active user sessions when an account is deactivated. Due to a logic flaw in the backend design, account state changes are enforced only during authentication (login), not for already-established sessions. The system implicitly assumes that authenticated users remain trusted for the lifetime of their session. There is no session expiration or account expiration mechanism in place, causing deactivated accounts to retain indefinite access until the user manually logs out. This behavior breaks the intended access control policy and results in persistent unauthorized access, representing a critical security flaw. This issue has been patched in version 0.31.0.0.

CVSS 8.8 · Высокий · EPSS 0,5% · Есть исправление

Опубликовано
Обновлено

Стек: php

Затронутые продукты и версии

  • ci4ms

    Версии
    • < 0.31.0.0: Затронуто

    Нет опубликованного исправления

  • ci4-cms-erp/ci4ms Packagist

    Версии
    • 0.21.0
    • 0.21.1
    • 0.21.2
    • 0.21.3
    • 0.21.3.1
    • 0.21.3.2
    • 0.21.3.3
    • 0.21.3.4
    • 0.21.3.5
    • 0.21.3.6
    • 0.21.3.7
    • 0.23.0.0
    • 0.23.0.1
    • 0.23.0.2
    • 0.23.1.0
    • 0.24.0.0
    • 0.24.0.16
    • 0.24.0.18
    • 0.24.0.19
    • 0.24.0.20
    • 0.24.0.27
    • 0.24.0.42
    • 0.24.0.45
    • 0.24.0.60
    • 0.25.0.0
    • 0.25.0.1
    • 0.25.0.2
    • 0.25.0.30
    • 0.25.0.39
    • 0.25.0.43
    • 0.25.1.0
    • 0.25.2.0
    • 0.25.3.0
    • 0.26.0.0
    • 0.26.1.0
    • 0.26.2.0
    • 0.26.3.0
    • 0.26.3.1
    • 0.26.3.2
    • 0.26.3.3
    • 0.26.3.4
    • 0.27.0.0
    • 0.28.0.0
    • 0.28.3.0
    • 0.28.4.0
    • 0.28.5.0
    • 0.28.6.0
    Затронутые диапазоны версий
    • ECOSYSTEM: < 0.31.0.0

    Обновитесь до 0.31.0.0

Первоисточники

Проверьте свой сервер →