CVE-2026-34589
CVE-2026-34589 · OpenEXR: DWA Lossy Decoder Heap Out-of-Bounds Write
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
OpenEXR provides the specification and reference implementation of the EXR file format, an image storage format for the motion picture industry. From 3.2.0 to before 3.2.7, 3.3.9, and 3.4.9, the DWA lossy decoder constructs temporary per-component block pointers using signed 32-bit arithmetic. For a large enough width, the calculation overflows and later decoder stores operate on a wrapped pointer outside the allocated rowBlock backing store. This vulnerability is fixed in 3.2.7, 3.3.9, and 3.4.9.
CVSS 8.4 · Высокий · EPSS 0,4% · Есть исправление
- Опубликовано
- Обновлено
Затронутые продукты и версии
openexr
- Версии
- >= 3.2.0, < 3.2.7: Затронуто
- >= 3.3.0, < 3.3.9: Затронуто
- >= 3.4.0, < 3.4.9: Затронуто
Нет опубликованного исправления
openexr Debian:12
- Версии
- 3.1.13-1
- 3.1.13-2
- 3.1.5-5
- 3.1.5-5.1
- 3.1.5-5.1+hurd.1
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
openexr Debian:13
- Версии
- 3.1.13-2
- 3.4.14-0.1
- 3.4.15+ds-1
- 3.4.16+ds-1
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- 3.5.2+ds-1
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
openexr Debian:14
- Версии
- 3.1.13-2
- 3.4.6+ds-1
- 3.4.6+ds-2
- 3.4.6+ds-3
- 3.4.6+ds-4
- Затронутые диапазоны версий
- ECOSYSTEM: < 3.4.14-0.1
Обновитесь до 3.4.14-0.1
openexr PyPI
- Версии
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.2.0, < 3.2.7
Обновитесь до 3.2.7
openexr PyPI
- Версии
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.3.0, < 3.3.9
Обновитесь до 3.3.9
openexr PyPI
- Версии
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- 3.4.8
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.4.0, < 3.4.9
Обновитесь до 3.4.9
openexr PyPI
- Версии
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.3.0
- 3.3.1
- 3.3.2
- 3.3.3
- 3.3.4
- 3.3.5
- 3.3.6
- 3.3.7
- 3.3.8
- 3.4.0
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- 3.4.8
- Затронутые диапазоны версий
- ECOSYSTEM: ≥ 3.2.0, < 3.2.7 ∪ ≥ 3.3.0, < 3.3.9 ∪ ≥ 3.4.0, < 3.4.9
Обновитесь до 3.2.7; Обновитесь до 3.3.9; Обновитесь до 3.4.9
openexr Ubuntu:26.10
- Версии
- 3.1.13-2build1
- 3.4.6+ds-4ubuntu3
- Затронутые диапазоны версий
- ECOSYSTEM: (−∞, +∞)
Нет опубликованного исправления
Первоисточники
- https://github.com/AcademySoftwareFoundation/openexr/security/advisories/GHSA-p8xc-w3q4-h64x
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.2.7
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.3.9
- https://github.com/AcademySoftwareFoundation/openexr/releases/tag/v3.4.9
- https://access.redhat.com/security/cve/CVE-2026-34589
- https://bugzilla.redhat.com/show_bug.cgi?id=2455411
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-34589.json
- https://nvd.nist.gov/vuln/detail/CVE-2026-34589