CVE-2026-40155
CVE-2026-40155 · Auth0 Next.js SDK has Improper Proxy Cache Lookup
Здесь приведены факты из открытых источников об уязвимостях. Перед обновлением ознакомьтесь с исходным сообщением.
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. In versions 4.12.0 through 4.17.1, simultaneous requests that trigger a nonce retry may cause the proxy cache fetcher to perform improper lookups for the token request results. Users are affected if their project uses both the vulnerable versions and the proxy handler /me/* and /my-org/* with DPoP enabled. This issue has been fixed in version 4.18.0.
CVSS 5.4 · Средний · EPSS 0,2% · Есть исправление
- Опубликовано
- Обновлено
Стек: node
Затронутые продукты и версии
nextjs-auth0
- Версии
- >= 4.12.0, < 4.18.0: Затронуто
Нет опубликованного исправления
@auth0/nextjs-auth0 npm
- Затронутые диапазоны версий
- SEMVER: ≥ 4.12.0, < 4.18.0
Обновитесь до 4.18.0